Instalation de mods/plugin pour un serveur sous bukkit 1.6.4 R2.0

Discussion dans 'Support minecraft : les serveurs' créé par jonathan345, 16 Décembre 2013.

  1. jonathan345

    • Nouveau
    Messages:
    6
    J'aime reçus:
    0
    Bonjour, je suis actuellement en train de créer mon propre serveur minecraft et, étant novice en la matière, j'aurai bien besoin d'un peu d'aide extérieur.

    Actuellement je bloque sur l’installation d'un plugin en particulier : CréativeGates. Je vais vous expliquer mon problème en étant le plus clair possible.

    Premièrement, mon serveur tourne sous bukkit 1.6.4 R2.0, j'ai installé dessus Essentials, WorldEdit et Lockette qui fonctionne tous les trois parfaitement bien.

    J'ai put lire que pour que CréativeGates fonctionne il faut MCore, je l'ai donc télécharger comme CréativeGates en version 1.6.4 R2.0, ce qui me semble logique.

    J'ai arrêté mon serveur, et ai placé les deux fichiers .jar dans plugins puis j'ai redémarrer mon serveur. Pour voir si le plugin fonctionnait bien j'ai créer un portail en premier lieu avec un bloc de diamant sur la base du bat de mon portail puis avec une montre j'ai tenter de l'activer avec un clique droit.

    Voyant que cela ne fonctionnait pas j'ai tenter de trouver une solution et j'en ai trouver deux. La première était de renommer la montre avec une enclume et la deuxième était qu'il ne fallait pas un bloc de diamant mais deux bloc d’émeraude.

    J'ai donc fait les modifications mais toujours rien... Je me suis donc demander : "Est-ce que le plugin c'est bien intallé ?" j'ai tapé la commande /plugin dans le chat In Game et la rien le plugin n'était pas installé et MCore non plus.

    Je suis allé voir dans le dossier de mon serveur via mon FTP (Filezilla) et j'ai remarqué que que ce soit pour CréativeGates ou pour MCore, aucun dossier n'avait été créé.

    Quelqu'un aurait-il la solution ?
  2. beubeulone

    • Feignant
    Messages:
    219
    J'aime reçus:
    38
    Regarde dans les logs au démarrage, la réponse y est peut-être.
  3. jonathan345

    • Nouveau
    Messages:
    6
    J'aime reçus:
    0
    en regardant les logs j'obtiens cela :

    Code:
    [INFO] §eNAME left the game.
    2013-12-16 08:14:43 [SEVERE] null
    java.io.IOException: Input/output error
        at java.io.FileInputStream.readBytes(Native Method)
        at java.io.FileInputStream.read(FileInputStream.java:220)
        at java.io.BufferedInputStream.fill(BufferedInputStream.java:218)
        at java.io.BufferedInputStream.read(BufferedInputStream.java:237)
        at java.io.FilterInputStream.read(FilterInputStream.java:66)
        at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader$1.read(ConsoleReader.java:167)
        at org.bukkit.craftbukkit.libs.jline.internal.InputStreamReader.read(InputStreamReader.java:267)
        at org.bukkit.craftbukkit.libs.jline.internal.InputStreamReader.read(InputStreamReader.java:204)
        at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readCharacter(ConsoleReader.java:995)
        at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readLine(ConsoleReader.java:1167)
        at net.minecraft.server.v1_6_R3.ThreadCommandReader.run(ThreadCommandReader.java:31)
    2013-12-16 08:14:47 [INFO] Starting minecraft server version 1.6.4
    2013-12-16 08:14:47 [INFO] Loading properties
    2013-12-16 08:14:47 [INFO] Default game type: CREATIVE
    2013-12-16 08:14:47 [INFO] Generating keypair
    2013-12-16 08:14:47 [INFO] Starting Minecraft server on 188.165.239.202:32990
    2013-12-16 08:14:47 [INFO] This server is running CraftBukkit version git-Bukkit-1.6.4-R2.0-b2918jnks (MC: 1.6.4) (Implementing API version 1.6.4-R2.0)
    2013-12-16 08:14:47 [SEVERE] Could not load 'plugins/mcore.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/massivecraft/mcore/MCore : Unsupported major.minor version 51.0
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:184)
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:305)
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:230)
        at org.bukkit.craftbukkit.v1_6_R3.CraftServer.loadPlugins(CraftServer.java:241)
        at org.bukkit.craftbukkit.v1_6_R3.CraftServer.<init>(CraftServer.java:219)
        at net.minecraft.server.v1_6_R3.PlayerList.<init>(PlayerList.java:56)
        at net.minecraft.server.v1_6_R3.DedicatedPlayerList.<init>(SourceFile:11)
        at net.minecraft.server.v1_6_R3.DedicatedServer.init(DedicatedServer.java:107)
        at net.minecraft.server.v1_6_R3.MinecraftServer.run(MinecraftServer.java:393)
        at net.minecraft.server.v1_6_R3.ThreadServerApplication.run(SourceFile:583)
    Caused by: java.lang.UnsupportedClassVersionError: com/massivecraft/mcore/MCore : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at org.bukkit.plugin.java.PluginClassLoader.findClass0(PluginClassLoader.java:80)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:53)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:247)
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:173)
        ... 9 more
    2013-12-16 08:14:47 [SEVERE] Could not load 'plugins/CreativeGates.jar' in folder 'plugins'
    org.bukkit.plugin.UnknownDependencyException: mcore
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:195)
        at org.bukkit.craftbukkit.v1_6_R3.CraftServer.loadPlugins(CraftServer.java:241)
        at org.bukkit.craftbukkit.v1_6_R3.CraftServer.<init>(CraftServer.java:219)
        at net.minecraft.server.v1_6_R3.PlayerList.<init>(PlayerList.java:56)
        at net.minecraft.server.v1_6_R3.DedicatedPlayerList.<init>(SourceFile:11)
        at net.minecraft.server.v1_6_R3.DedicatedServer.init(DedicatedServer.java:107)
        at net.minecraft.server.v1_6_R3.MinecraftServer.run(MinecraftServer.java:393)
        at net.minecraft.server.v1_6_R3.ThreadServerApplication.run(SourceFile:583)
    2013-12-16 08:14:47 [SEVERE] Could not load 'plugins/Factions.jar' in folder 'plugins'
    org.bukkit.plugin.UnknownDependencyException: mcore
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:195)
        at org.bukkit.craftbukkit.v1_6_R3.CraftServer.loadPlugins(CraftServer.java:241)
        at org.bukkit.craftbukkit.v1_6_R3.CraftServer.<init>(CraftServer.java:219)
        at net.minecraft.server.v1_6_R3.PlayerList.<init>(PlayerList.java:56)
        at net.minecraft.server.v1_6_R3.DedicatedPlayerList.<init>(SourceFile:11)
        at net.minecraft.server.v1_6_R3.DedicatedServer.init(DedicatedServer.java:107)
        at net.minecraft.server.v1_6_R3.MinecraftServer.run(MinecraftServer.java:393)
        at net.minecraft.server.v1_6_R3.ThreadServerApplication.run(SourceFile:583)
    2013-12-16 08:14:47 [INFO] [Lockette] Loading Lockette v1.7.12
    2013-12-16 08:14:47 [INFO] [WorldEdit] Loading WorldEdit v5.5.8
    2013-12-16 08:14:47 [INFO] [Essentials] Loading Essentials v2.11.1
    2013-12-16 08:14:47 [INFO] [EssentialsChat] Loading EssentialsChat v2.11.1
    2013-12-16 08:14:47 [INFO] [EssentialsProtect] Loading EssentialsProtect v2.11.1
    2013-12-16 08:14:47 [INFO] [EssentialsSpawn] Loading EssentialsSpawn v2.11.1
    2013-12-16 08:14:47 [INFO] [EssentialsAntiBuild] Loading EssentialsAntiBuild v2.11.1
    2013-12-16 08:14:47 [WARNING] **** SERVER IS RUNNING IN OFFLINE/INSECURE MODE!
    2013-12-16 08:14:47 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    2013-12-16 08:14:47 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    2013-12-16 08:14:47 [WARNING] To change this, set "online-mode" to "true" in the server.properties file.
    2013-12-16 08:14:47 [INFO] Preparing level "world"
    2013-12-16 08:14:47 [INFO] Preparing start region for level 0 (Seed: -7497564628257033198)
    2013-12-16 08:14:48 [INFO] Preparing spawn area: 44%
    2013-12-16 08:14:49 [INFO] Preparing start region for level 1 (Seed: -7497564628257033198)
    2013-12-16 08:14:49 [INFO] Preparing start region for level 2 (Seed: -7497564628257033198)
    2013-12-16 08:14:49 [INFO] [Lockette] Enabling Lockette v1.7.12
    2013-12-16 08:14:49 [INFO] [Lockette] Version 1.7.12 is being enabled!  Yay!  (Core version 1.3.7)
    2013-12-16 08:14:49 [INFO] [Lockette] Detected craftbukkit build [2918] ok.
    2013-12-16 08:14:49 [INFO] [Lockette] Custom lockable block list: [116, 84, 57, 145, 154]
    2013-12-16 08:14:49 [INFO] [Lockette] Ignoring linked plugins: [mcMMO]
    2013-12-16 08:14:49 [INFO] [Lockette] Loading strings file for English by Acru
    2013-12-16 08:14:49 [INFO] [Lockette] Using ops file for admin permissions.
    2013-12-16 08:14:49 [INFO] [Lockette] Ready to protect your containers.
    2013-12-16 08:14:49 [INFO] [WorldEdit] Enabling WorldEdit v5.5.8
    2013-12-16 08:14:49 [INFO] WEPIF: Using the Bukkit Permissions API.
    2013-12-16 08:14:49 [INFO] [Essentials] Enabling Essentials v2.11.1
    2013-12-16 08:14:50 [INFO] Essentials: Using config file enhanced permissions.
    2013-12-16 08:14:50 [INFO] Permissions listed in as player-commands will be given to all users.
    2013-12-16 08:14:50 [INFO] [EssentialsChat] Enabling EssentialsChat v2.11.1
    2013-12-16 08:14:50 [INFO] [EssentialsProtect] Enabling EssentialsProtect v2.11.1
    2013-12-16 08:14:50 [INFO] [EssentialsSpawn] Enabling EssentialsSpawn v2.11.1
    2013-12-16 08:14:50 [INFO] [EssentialsAntiBuild] Enabling EssentialsAntiBuild v2.11.1
    2013-12-16 08:14:50 [WARNING] Server permissions file permissions.yml is not valid YAML.
    java.lang.ClassCastException: java.lang.String cannot be cast to java.util.Map
        at org.bukkit.craftbukkit.v1_6_R3.CraftServer.loadCustomPermissions(CraftServer.java:636)
        at org.bukkit.craftbukkit.v1_6_R3.CraftServer.enablePlugins(CraftServer.java:272)
        at net.minecraft.server.v1_6_R3.MinecraftServer.l(MinecraftServer.java:315)
        at net.minecraft.server.v1_6_R3.MinecraftServer.f(MinecraftServer.java:292)
        at net.minecraft.server.v1_6_R3.MinecraftServer.a(MinecraftServer.java:252)
        at net.minecraft.server.v1_6_R3.DedicatedServer.init(DedicatedServer.java:152)
        at net.minecraft.server.v1_6_R3.MinecraftServer.run(MinecraftServer.java:393)
        at net.minecraft.server.v1_6_R3.ThreadServerApplication.run(SourceFile:583)
    2013-12-16 08:14:50 [INFO] Done (2,551s)! For help, type "help" or "?"
    2013-12-16 08:14:50 [INFO] Starting GS4 status listener
    2013-12-16 08:14:50 [INFO] Starting remote control listener
    2013-12-16 08:14:50 [INFO] Query running on 188.165.xxx.xxx:xxxxx
    2013-12-16 08:14:50 [INFO] RCON running on 188.165.xxx.xxx:xxxxx
    
    Mais pour moi c'est du charabia... Pourrai-tu m'expliquer ou trouver l'erreur et comment faire pour la trouver que je puisse me débrouiller pour la prochaine fois ou je devrai aller voir les logs ?
  4. robin4002

    • Support technique
    Messages:
    3 695
    J'aime reçus:
    498
    Code:
    Unsupported major.minor version 51.0
    Ce plugins a besoin de java 7, or tu as une ancienne version de java, il faut que tu installes java 7.
  5. jonathan345

    • Nouveau
    Messages:
    6
    J'aime reçus:
    0
    Non le problème ne vient pas de la puisque ma version de java est a jour et que ce soit la 32 bit comme la 64 bit
  6. robin4002

    • Support technique
    Messages:
    3 695
    J'aime reçus:
    498
    Si si, ça peut que être ça, désinstalle tes anciennes versions de java.
    Je peux voir ton .bat ?
  7. jonathan345

    • Nouveau
    Messages:
    6
    J'aime reçus:
    0
    Si tu me dit ou je peux le trouver uniquement car comme je l'ai dit dans mon premier poste je suis novice en la matière
  8. robin4002

    • Support technique
    Messages:
    3 695
    J'aime reçus:
    498
    Ha, attend, tu as un serveur en local ou un serveur chez un hébergeur ?
  9. jonathan345

    • Nouveau
    Messages:
    6
    J'aime reçus:
    0
  10. robin4002

    • Support technique
    Messages:
    3 695
    J'aime reçus:
    498
    Le problème vient donc de ton hébergeur, la version de java sur ton hébergeur n'est pas à jour, donc le plugins ne fonctionne pas. Il faut que tu vois avec ton hébergeur s'il peut mettre java 7 sur leurs machines.

Partager cette page