Configuration Plugin Problème des plugins sur mon serveur.

RYXY

Bucheron
15 Février 2021
34
1
0
6
20
Bonjour comme expliqué dans le titre j'ais un problème avec les plugins: une fois sur dix ils marches sinon sa me met:
j'utilise comme plugin:
-chestcommands, clearlag, creazy auction, custom join item, essential spawn, essential chat, essential, helth bar, luck perm, mine web bridge, mysqllayerdatabridge, trade me, vault, world edit et world guard. merci d'avance.
 

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 196
45
327
217
19
Mìlhüsa
Bonsoir,

Essaye de mettre à jour tous tes plugins, par ex. tu as Crazy Auctions 1.2.10, la dernière en date est la 1.2.16.

Cordialement,
ShE3py
 

RYXY

Bucheron
15 Février 2021
34
1
0
6
20
Bonsoir,

Essaye de mettre à jour tous tes plugins, par ex. tu as Crazy Auctions 1.2.10, la dernière en date est la 1.2.16.

Cordialement,
ShE3py
oui mais la version supérieur du plugin ne marches pas. c'est le plugin essential qui fait tout bug or j'en ait besoin pour mon serveur qui est un pvp faction j'aimerait savoir de quelle partie d'essential fait bug mes plugin svp
 

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 196
45
327
217
19
Mìlhüsa
Envoie les logs de ton serveur lorsque tous les mods sont à jour et qu'Essentials « fait tout bug ».
 

RYXY

Bucheron
15 Février 2021
34
1
0
6
20
Envoie les logs de ton serveur lorsque tous les mods sont à jour et qu'Essentials « fait tout bug ».
là tu risque de ne rien voir mais j'avait déjà tenté sans le plugin essential et sa avait marché.
 

Fichiers joints

  • 2021-07-10-1.log
    903.2 KB · Affichages: 11

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 196
45
327
217
19
Mìlhüsa
Tu utilises un serveur (Cauldron, Mohist ou que sais-je) qui « permet » d'avoir à la fois des mods Forge et des plugins Bukkit, or cela fonctionne rarement correctement, pour ainsi dire jamais.

Le seul truc propre qui permet d'avoir des mods et des plugins à l'heure actuelle est SpongeForge, mais il ne fonctionne qu'avec les plugins Sponge et non Bukkit.
 

RYXY

Bucheron
15 Février 2021
34
1
0
6
20
Tu utilises un serveur (Cauldron, Mohist ou que sais-je) qui « permet » d'avoir à la fois des mods Forge et des plugins Bukkit, or cela fonctionne rarement correctement, pour ainsi dire jamais.

Le seul truc propre qui permet d'avoir des mods et des plugins à l'heure actuelle est SpongeForge, mais il ne fonctionne qu'avec les plugins Sponge et non Bukkit.
J'utilise CatServer qui est un dérivé de Cauldron mais moi on m'a toujours dit que cauldron marchait mieux que SpongeForge. Je v'ais voir dans la config d'essential pour voir les bugs.
 

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 196
45
327
217
19
Mìlhüsa
Cauldron permet d'avoir des plugins Bukkit, ce que Sponge ne permet pas ; en ce sens, il « marche mieux ».

En revanche, ce n'est pas rare que des plugins Bukkit sont conçus pour fonctionner sur Bukkit et sur Spigot, ou quelque chose qui y ressemble tel que Paper. Or Cauldron est basé sur Forge qui ne ressemble pas du tout à Spigot, donc un plugin qui en théorie fonctionne peut ne pas fonctionner sur Cauldron parce qu'il a été pensé pour fonctionner uniquement sur Spigot.

La différence avec Sponge est que les plugins Sponge sont eux fait pour fonctionner sur Sponge ; si tu essayais de mettre un plugin Sponge sur un serveur Spigot tu aurais le même problème d'incompatibilité.

TL;DR les plugins Bukkit sont développés pour Spigot/Paper, et non pour Cauldron/Forge. Tant mieux pour toi si ça marche, mais les plugins Bukkit n'ont jamais été conçus pour fonctionner avec Cauldron.