Que faut il pour un serveur Minecraft ?

Fewlaz

Nouveau
19 Avril 2021
12
0
1
21
Salut tout le monde, je vous explique mon problème, j'aimerais créer un petit serveur Publique Chill, j'ai un serveur de 8go ram avec un bon proco. Et j'aimerais savoir combien de joueurs au maximum peut il contenir en simultané, voici toutes mes caractéristiques.

Voici ce que j'envisage
  • chaque joueur est dans son coin, avec une render distance de 8 ou 6 chunks (défini sur le serveur)
  • le serveur est sur paper (la version seras expliqué après)
  • environ 40 plugins
  • entre 1 et 3 mondes

La version :
j'aimerais savoir la quelle est la mieux optimisé et tourne avec le plus de joueur, donc ce que je veux savoir :
  • le nombre de joueurs que je peux faire tourner sur un 8gb ram
  • avec quel version (la plus optimisé possible
 

Monsieur Yaourt

Massacreur de zombies
2 Septembre 2014
69
5
111
30
Je pense que tu sous estime la difficulté d'avoir des joueurs sur ton serveur. Sinon la j'pense que tu peux avoir 45-60 joueurs (ça dépend de t'es plugins)
 

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
10 357
21
2 222
347
25
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

C'est "débile" de réfléchir comme ça...
Ca veut dire que ton serveur ne va jamais évoluer de version ? Vu que tu va choisir la version en fonction de "l'optimisation"...
Pareil pour les plugins. Si tu installes 40 plugins aussi gros que Essentials ou Faction, ça va être impossible. Si tes 40 plugins sont des plugins de tchat, c'est chill....
Un plugin n'en vaut pas un autre.

Bref, moi ce que je te conseil: voit petit et au pire tu pourra augmenter après.
Prend la version où tu as le plus de choses dont tu as besoin et/ou la version la plus joué par les joueurs que tu cibles (pour un serveur "surive" je te conseil de prendre les versions les plus à jour (1.17 à l'heure actuelle)). Et si tu as "trop de monde", tu regarde pour prendre une machine plus puissante.
Il est important de noter que la plupart des hébergeurs seront très heureux de te voir souscrire à une offre plus importante (plus de sous pour eux...). Donc une évolution d'une machine "faible" à une machine "plus puissante" sera généralement (voir toujours) accepté par l'hébergeur (qui peut même t'aider à migrer tes fichiers voir même t'éviter une migration (ils vont juste changer les caractéristiques de ton VPS)).


Cordialement,
Detobel36
 

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 196
45
327
217
19
Mìlhüsa
Bonjour,

le nombre de joueurs que je peux faire tourner sur un 8gb ram
On peut éventuellement rajouter 8 Go de RAM à un piano numérique, pas sûr qu'il fasse tourner beaucoup de joueurs si on installe un serveur Minecraft dessus.
Ce qui est réellement important c'est le processeur, la mémoire ne servira pas à grand-chose si le processeur ne suit pas la charge.

avec quel version (la plus optimisé possible
Ce n'est pas parce que quelque chose est optimisé qu'il est rapide, ça veut simplement dire qu'il n'y a pas plus efficient pour ce que l'on veut faire.
Tu ne peux pas dire que la 1.17 est plus optimisée que la 1.16, parce que ce n'est tout simplement pas le même jeu, les deux versions ne font pas la même chose et ne sont donc pas comparables.

Quel est le plus optimisé entre résoudre un Rubik's Cube 2x2x2 et un Rubik's Cube 3x3x3 ? La question n'a pas de sens, si tu veux résoudre un Rubik's Cube 3x3x3 plus rapidement tu apprends des nouvelles formules de résolution, tu ne résous pas un 2x2x2.

Maintenant si tu as un serveur 1.17, et que tu veux l'optimiser, tu peux passer par Paper — ce que tu fais déjà — qui ajoute des options pour alléger les calculs, mais en aucun cas tu ne fais quelque chose avec une autre version.
Et si tu parlais de la vitesse, alors dans ce cas-là uniquement tu peux dire qu'effectivement, résoudre un 2x2x2 est plus rapide qu'un 3x3x3, parce que la vitesse/durée n'a aucun lien avec ce que tu chronomètres. L'optimisation est quant à elle liée à l'objet que tu optimises — elle n'a aucun lien avec les autres objets.

Donc concrètement, tu peux optimiser une version particulière du jeu, tu peux demander quelle est la version la plus rapide du jeu, mais tu ne peux pas demander quelle est la version la plus optimisée du jeu.

Et si tu veux savoir quelle est la version la plus rapide du jeu, probablement la pre-Classic rd-131655.

C'est pas sa le problème, c'est le problème niveau budget...
Pas la peine de mettre des points de suspension comme si nous étions censés deviner ce fait.
Je ne pense pas que tu paieras plus ou moins en hébergement selon la version que tu utilises ; les plugins que tu utilises influenceront beaucoup beaucoup plus là-dessus. Gagner en performances passera plus par la configuration des plugins et de Paper que par la version du jeu en elle-même.

Tu dois juste choisir la version du jeu en fonction de tes préférences et des plugins que te souhaites — à noter que les anciennes versions (⩽ 1.15) sont généralement abandonnées par les développeurs. Donc pour un serveur survie, le mieux serait la 1.17.

Cordialement,
ShE3py
 

Fewlaz

Nouveau
19 Avril 2021
12
0
1
21
Salut, dans "la version la plus optimisé" je voulais dire la plus rapide, comme tu l'as mentionné. Et non je ne prendrais pas la 1.17 car mon but est de faire une survie "avancé", c'est à dire avec des plugins dans le style faction, concrêtement sa serais un mélange entre un faction et une survie, il y a que un seul serveur/monde, un petit spawn, pas de plugin de faction mais un plugin de plot/claims (UltimateClaims) et il y a beaucoup de plugins qu'on retrouve dans les factions : Crazy Auctions, Trading et bien plus. Et oui je me suis très mal exprimé dans ma demande.
 

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 196
45
327
217
19
Mìlhüsa
Les plugins Bukkit ne fonctionnent pas comme les mods, il y a de très grandes chances qu'ils fonctionneront en 1.17 même s'ils ont été faits pour la 1.16, donc en soit tu peux toujours essayer.

Sinon il faudrait aller en 1.16.5, mais après le problème c'est que tu ne pourras pas vraiment changer de version (aller en 1.17/1.18) sans réinitialiser la map, notamment avec les Y négatifs, aucune idée de ce que ce que la conversion 1.17 → 1.18 donnera.

Ce que tu peux faire pour le moment c'est développer et configurer ton serveur en 1.16, et voir ensuite si ça vaut le coup de le passer en 1.17 avant son ouverture — n'oublie pas de faire une backup avant d'essayer de changer de version.