Configuration [VPS] Passer de java 52 à 55 sous Linux.

Kenda

Massacreur de zombies
16 Juillet 2016
242
1
2
125
29
www.youtube.com
Bonjour,

Acutllement en train de configuré un vps pour un ami, j'ai mis un plugin, mais ce dernier n'est pas compatible avec la version java du vps. J'aimerai donc savoir comment mettre cette fameuse version 55 au lieu de la 52. :)


Code:
[13:12:58 WARN]: Error loading plugin ServerSelectorX
java.lang.UnsupportedClassVersionError: xyz/derkades/serverselectorx/Main has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
        at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_282]
        at java.lang.ClassLoader.defineClass(ClassLoader.java:756) ~[?:1.8.0_282]
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.8.0_282]
        at net.md_5.bungee.api.plugin.PluginClassloader.findClass(PluginClassloader.java:146) ~[bungeecord.jar:git:Waterfall-Bootstrap:1.17-R0.1-SNAPSHOT:e6526b1:445]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:418) ~[?:1.8.0_282]
        at net.md_5.bungee.api.plugin.PluginClassloader.loadClass0(PluginClassloader.java:66) ~[bungeecord.jar:git:Waterfall-Bootstrap:1.17-R0.1-SNAPSHOT:e6526b1:445]
        at net.md_5.bungee.api.plugin.PluginClassloader.loadClass(PluginClassloader.java:59) ~[bungeecord.jar:git:Waterfall-Bootstrap:1.17-R0.1-SNAPSHOT:e6526b1:445]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:351) ~[?:1.8.0_282]
        at net.md_5.bungee.api.plugin.PluginManager.enablePlugin(PluginManager.java:394) ~[bungeecord.jar:git:Waterfall-Bootstrap:1.17-R0.1-SNAPSHOT:e6526b1:445]
        at net.md_5.bungee.api.plugin.PluginManager.loadPlugins(PluginManager.java:300) ~[bungeecord.jar:git:Waterfall-Bootstrap:1.17-R0.1-SNAPSHOT:e6526b1:445]
        at net.md_5.bungee.BungeeCord.start(BungeeCord.java:278) ~[bungeecord.jar:git:Waterfall-Bootstrap:1.17-R0.1-SNAPSHOT:e6526b1:445]
        at net.md_5.bungee.BungeeCordLauncher.main(BungeeCordLauncher.java:67) ~[bungeecord.jar:git:Waterfall-Bootstrap:1.17-R0.1-SNAPSHOT:e6526b1:445]
        at net.md_5.bungee.Bootstrap.main(Bootstrap.java:15) ~[bungeecord.jar:git:Waterfall-Bootstrap:1.17-R0.1-SNAPSHOT:e6526b1:445]


Merci bien :)
 

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 196
45
327
217
19
Mìlhüsa
Bonjour,

Ton plugin a été compilé pour Java SE 11 (55.0) mais ton serveur tourne sous Java 8 (52.0), essaye d'installer OpenJDK 11.

Cordialement,
ShE3py
 

Kenda

Massacreur de zombies
16 Juillet 2016
242
1
2
125
29
www.youtube.com
Bonjour,

Ton plugin a été compilé pour Java SE 11 (55.0) mais ton serveur tourne sous Java 8 (52.0), essaye d'installer OpenJDK 11.

Cordialement,
ShE3py
Le problème, quand j'essaye d'installer JDK 11, il me met une erreur :
Code:
E: Unable to locate package openjdk-11-jdk
Ducoup je suis bien embéter, sinon faudrait décompiler le plugin et le recompiler dans la bonne version, mais j'ai peur d'avoir des incompatibilité ?
 

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 196
45
327
217
19
Mìlhüsa
Quelle commande fais-tu pour installer le JDK ?

Ducoup je suis bien embéter, sinon faudrait décompiler le plugin et le recompiler dans la bonne version, mais j'ai peur d'avoir des incompatibilité ?
Il me semble que Paper 1.17 requiert au moins Java 11, et dans tous les cas si tu veux downgrade de version de Java il faudrait que tu modifies un peu le code source, parce que Java 8 n'a pas de modules et a des fonctions en moins.
 

Kenda

Massacreur de zombies
16 Juillet 2016
242
1
2
125
29
www.youtube.com
Quelle commande fais-tu pour installer le JDK ?


Il me semble que Paper 1.17 requiert au moins Java 11, et dans tous les cas si tu veux downgrade de version de Java il faudrait que tu modifies un peu le code source, parce que Java 8 n'a pas de modules et a des fonctions en moins.
Je fais la commande apt-get install openjdk-11-jre (comme le jdk 8 que j'avais installer).
Après j'utilise un paper 1.8.8, ducoup je pense aussi qu'il y aura des incompatibilités ?
 

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 196
45
327
217
19
Mìlhüsa
Bash:
sudo add-apt-repository ppa:openjdk-r/ppa
sudo apt-get update
sudo apt-get install openjdk-11-jre-headless

Après j'utilise un paper 1.8.8, ducoup je pense aussi qu'il y aura des incompatibilités ?
Aucune idée il faudra essayer, mais du coup si tu peux pas lancer Paper 1.8 avec Java 11 tu ne pourras pas avoir ton plugin « ServerSelectorX ».