Résolu Alerte sonore dans Minecraft SOLO et pose multiple de blocs.

locksher

Aventurier
15 Septembre 2019
4
0
2
28
Bonjour à tous et à toutes,

Depuis peu, je rencontre un problème très récurrent dans mes survies solos de Minecraft. Le problème peu sembler simple en apparence : par moment, lorsque je pose un bloc ou un objet (et uniquement quand je pose), une alerte sonore très discrète se fait entendre (une sorte de "bipbipbip" assez aigu). Cela ne se produit pas à chaque fois que je pose un bloc, mais très souvent. Trop à mon goût. Par moment, le même bruit se fait entendre, mais en plus de cela, je pose plusieurs blocs/objets au lieu d'un, généralement 1 ou 2 (Pour donner un ordre d'idée un peu au pif, sur 10 blocs posés, le signal se fait entendre 4 fois, 1 fois sur 4, des blocs se pose en trop.). J'ai remarqué que ce problème s'accompagnait régulièrement d'un "micro-freeze", tout aussi discret que l'alerte sonore qui l'accompagne. J'avais pour sûr de la latence sur mes parties solo.

Afin de lutter contre ce problème, j'ai cherché sur le monde merveilleux d'internet, mais en vain. J'ai donc essayé de résoudre le problème par moi-même. Dans un premier temps, j'ai alloué plus de RAM à Minecraft, passant de 2 à 4 gigas. J'ai supprimé de cette même manière la latence qui était bien présente. Cependant, le problème ne s'est pas arrangé. Plus de micro-freeze certes, mais toujours cette même alerte sonore, et par moment, le même problème de pose multiple de blocs. J'en suis venu à considérer que le problème venait de JAVA. Evidemment, rien ne semble poser de problème de ce côté là. JAVA est bien à jour. Comme mes DRIVERS de carte graphique et de souris.
Ayant déjà installé Optifine, j'ai commencé à soupçonner ce célèbre mod d'être la cause de mes soucis. Que nenni, après avoir relancé ma partie sur un profil "vanilla", le même problème s'est manifesté, encore et toujours.
Je suis allé voir également du coté des touches rémanentes. Elles sont désactivées, dans tous les cas et pour toutes les hypothèses possibles (j'avais imaginé que l'alerte sonore puisse venir de là).

J'avoue qu'à partir de là, je suis à court d'hypothèse. Je viens donc voir ici si quelqu'un avait une idée. Je précise que je joues évidemment sur la version Officielle et légale de Minecraft, en 1.14.4.
En vrac, voici un peu ma config de jeu : Mon ordinateur est un HP OMEN 15 PORTABLE - 8G RAM - Processeur INTEL CORE i5 7300HQ CPU 2.50GHZ 4 coeurs. Ma carte graphique est une NVIDIA GeForce GTX 1050 (faut-il le rappeler, ses pilotes sont à jours) . Enfin, j'utilise Windows 10 en 64 bits (et j'utilise la version JAVA x64 adéquate). Et même si je vois pas le rapport, on ne sait jamais, ma souris est une Kone AIMO de la marque ROCCAT (A jour dans ses drivers également).

J'attends vos réponses, parce qu'en vrai, je n'ai plus trop d'idée de quoi faire, un avis extérieur m'aiderait beaucoup. D'autant plus que ce problème à tendance, même s'il ne m'empêche pas de jouer, à me fatiguer.
En vous remerciant par avance.
 
Dernière édition:

robin4002

Expert en informatique et systèmes d'information
Staff
Responsable technique
Responsable forum
12 Novembre 2012
20 853
157
3 002
347
26
Alsace
www.minecraftforgefrance.fr
Bonsoir,

Il y a uniquement des problèmes sur Minecraft ou également dans d'autres programmes ?
Car là vu le problème décrit, je pense à un problème du pilote audio.
Faudrait voir si le problème se manifeste aussi quand la carte son est désactivé.

Vérifies aussi que ton jeu se lance sur la carte Nvidia et non sur le chipset graphique Intel (tu peux regarder ça en appuyant sur F3 en jeu et en regardant en haut à droite).
 

locksher

Aventurier
15 Septembre 2019
4
0
2
28
Bonsoir,

Il y a uniquement des problèmes sur Minecraft ou également dans d'autres programmes ?
Car là vu le problème décrit, je pense à un problème du pilote audio.
Faudrait voir si le problème se manifeste aussi quand la carte son est désactivé.

Vérifies aussi que ton jeu se lance sur la carte Nvidia et non sur le chipset graphique Intel (tu peux regarder ça en appuyant sur F3 en jeu et en regardant en haut à droite).

Le problème ne se présente que sur Minecraft. De plus, j'ai du mal à comprendre comment un problème audio peut générer des soucis ingame (mon problème de bloc, qui tient limite plus d'un problème de latence ingame, latence que je n'ai plus). Mais bon, je n'avais pas pensé aux drivers audio... j'ai vérifié, et ils sont à jour. J'ai également fait le test, comme tu me l'as conseillé, d'essayer de désactiver la carte son mais également de faire un diagnostic afin de régler les problèmes. Ni l'un ni l'autre n'a permis de mettre en exergue un problème particulier, je n'y vois pas de changement.

Sinon, j'ai déjà vérifier pour la carte NVIDIA, le jeu se lance bien sur cette dernière.
 

robin4002

Expert en informatique et systèmes d'information
Staff
Responsable technique
Responsable forum
12 Novembre 2012
20 853
157
3 002
347
26
Alsace
www.minecraftforgefrance.fr
De plus, j'ai du mal à comprendre comment un problème audio peut générer des soucis ingame (mon problème de bloc, qui tient limite plus d'un problème de latence ingame, latence que je n'ai plus).
Parce que si le pilote audio ne répond pas aux demandes de jouer du son envoyé par Minecraft ça peut causer des micro-freezes. J'ai déjà vu des cas comme ça.

Mais visiblement ce n'est pas le cas chez toi, donc là je n'ai pas d'autres pistes à explorer :/
 
  • J'aime
Reactions: locksher

locksher

Aventurier
15 Septembre 2019
4
0
2
28
Parce que si le pilote audio ne répond pas aux demandes de jouer du son envoyé par Minecraft ça peut causer des micro-freezes. J'ai déjà vu des cas comme ça.

J'ignorais totalement qu'une défaillance audio pouvait générer des freezes in-game. Au moins j'aurais appris quelque chose. Par pure curiosité, et à défaut d'avoir mieux, qu'elle est la marche à suivre dans ces cas là ? Et pourquoi juste avec Minecraft et pas d'autres jeux ?
 

robin4002

Expert en informatique et systèmes d'information
Staff
Responsable technique
Responsable forum
12 Novembre 2012
20 853
157
3 002
347
26
Alsace
www.minecraftforgefrance.fr
Comme tu as toujours le problème en désactivant le pilote audio ce n'est pas ça ton problème, il doit avoir autre chose qui bloque, mais je ne sais pas du tout quoi.

Dans le cas d'un problème de pilote audio en général une mise à jour du driver règle le souci.
 

locksher

Aventurier
15 Septembre 2019
4
0
2
28
Bon, je poste un dernier message ici parce que j'ai trouver LA solution à mon problème. J'ai eu un problème de curseur dans un autre jeu, qui était causé par l'Overlay de Discord. j'ai donc désactivé ce dernier. Ce qui a résolu mon problème sur Minecraft par la même occasion. Je laisse donc un modérateur archiver cette discussion ^^