Erreur de lancement (1.X ) sous Linux : Exit Code 127

Discussion dans 'Support Minecraft' créé par Silver_Hunter, 23 Avril 2019.

  1. TTheGlock

    TTheGlock Constructeur de Renom

    Inscrit:
    6 Août 2018
    Messages:
    5
    J'aime reçus:
    2
    Bonjour !

    Depuis que j'ai réinstallé Minecraft sous Ubuntu 19.04, un problème se pose déjà : Minecraft ne veut fonctionner qu'avec Java 8. Or, Java 8 est introuvable dans les bases de données : c'est une version trop vieille.
    J'ai pu contourner ce problème, pour finalement arriver à celui-ci. La seule version qui marche est la plus récente, déjà "présente" dans le launcher (ici actuellement la 1.14). Alors, je télécharge la version (ici la 1.12) , puis (PS : j'ai vérifié avec toutes les versions, aucune ne marche) elle se lance ... Setting User... LWJGL Version: 2.9.4... et là : BOUM !

    Inconsistency detected by ld.so: dl-lookup.c: 112: check_match: Assertion `version->filename == NULL || ! _dl_name_match_p (version->filename, map)' failed!

    Process crashed with exit code 127


    Quelqu'un aurait une idée pour résoudre ce problème ? Merci !
     

    Fichiers attachés:

  2. uiytt

    uiytt Développeur

    Inscrit:
    18 Août 2014
    Messages:
    50
    J'aime reçus:
    7
    Donc déjà je précise je m'y connais pas du tout mais on sait jamais...

    Ensuite, par contourner tu veux dire quoi ? Si on te donne une version de Java 8 ça ira ?
     
  3. Detobel36

    Detobel36 Créateur de plugins (PhoenixRebirth)
    Support

    Inscrit:
    17 Août 2012
    Messages:
    9 165
    J'aime reçus:
    1 937
    Salut,

    Java 8 est la version recommandée... Elle n'est pas du tout "vieille".
    Il n'y a qu'a voir le site officiel d'Oracle pour voir cela: https://www.java.com/en/download/linux_manual.jsp
    Le problème c'est d'être sous Ubuntu 19.04... C'est une version qui a moins d'un mois et qui en plus n'est pas LTS. Donc c'est possible que les libraires ne soit pas encore totalement à jour et qu'il ne supporte pas encore Java 8.


    Cordialement,
    Detobel36
     
  4. TTheGlock

    TTheGlock Constructeur de Renom

    Inscrit:
    6 Août 2018
    Messages:
    5
    J'aime reçus:
    2
    En fait, le problème n'est pas Java (je pense avoir mal formulé ma phrase ) mais ce message d'erreur et le fait que je ne puisse jouer qu'en 1.14...
     
  5. uiytt

    uiytt Développeur

    Inscrit:
    18 Août 2014
    Messages:
    50
    J'aime reçus:
    7
    Justement, c'est peut-être car tu n'as pas JAVA 8 la version nécessaire pour la 1.14..
    Quand tu fais java -version
    dans une console de commande tu as quoi ?
     
  6. TTheGlock

    TTheGlock Constructeur de Renom

    Inscrit:
    6 Août 2018
    Messages:
    5
    J'aime reçus:
    2
    J'ai réussi à régler le problème ! Je pense que le problème était bien java..
    Pour régler le problème, j'ai fait
    1- sudo add-apt-repository ppa:openjdk-r/ppa

    2- sudo apt update

    3- sudo apt install openjdk-8-jdk openjdk-8-jre

    Et le tour est joué !
    Merci quand même pour vos réponses !
     
    robin4002 et uiytt aiment ça.
  7. robin4002

    robin4002 Étudiant en informatique
    Staff Responsable technique Responsable forum

    Inscrit:
    12 Novembre 2012
    Messages:
    16 158
    J'aime reçus:
    2 589
    En effet les anciennes versions de MC supportent mal les nouvelles versions de Java (en soit ce n'est pas étonnant, il y a eu beaucoup de modif dans les nouvelles versions de Java).
     

Partager cette page