Configuration Plugin EssentialsX

Moutmoutéo

Staff manager et rédacteur
29 Mars 2020
4
0
2
17
France
Bonjour,

Je recherche quelqu'un qui serait me faire une configuration de la local "fr properties" de EssentialsX.
Car je ne comprend pas parfois ou il manque des "é" ou bien-même elle plante car je suis sûr que c'est forcément moi qui a mal fait la chose.

Ayant passer 3 jours à recommencer sur une simple configuration, j'ai finit par craquer, j'ai besoin d'aide !

Merci au personne qui se proposerons de me venir en aide !

- Matéo
 
Dernière édition:

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
9 748
17
2 146
347
24
Bruxelles - Belgique
www.phoenix-rebirth.fr

Moutmoutéo

Staff manager et rédacteur
29 Mars 2020
4
0
2
17
France
Salut,

Heu... Normalement si tu changes simplement le local: fr dans la configuration tu as directement la version fr...
Essentials est tellement utilisé qu'il y a déjà de base dedans une version fr.

Et si vraiment tu veux avoir le fichier dans ton dossier "plugins/essentials", tu as la version Fr ici: https://github.com/EssentialsX/Essentials/blob/2.x/Essentials/src/messages_fr.properties


Cordialement,
Detobel36

Bonjour @Detobel36,
Sa faisait un moment que je ne t'avais pas revue, j'espère que tu va bien ^-^ !

En ce qui concerne cela, oui ne t'inquiète pas, modifier des choses n'est pas compliqué et heureusement lol.
Je l'est déjà bien mis en français et tout fait correctement dessus étant donner que mes joueurs jouent déjà sur le serveur actuellement.

Le bémol, c'est que je ne comprend pas la personnalisation du fichier de la langue (UTF-8 il me semble) ce qui fait que certaines choses sont étranges à mes yeux.

Il y a des lignes ou on ne voit même plus les "E" par exemple..

Le fichier que tu m'a envoyé ma l'air cool car il n'y a que des §5 pour les couleurs et non le format UTF-8 !
Est-il à jour ? Puis-je donc le mettre une fois finit sur la machine sans soucis avec des "é" et ce format couleur ?

Merci d'avance

- Matéo
 

Moutmoutéo

Staff manager et rédacteur
29 Mars 2020
4
0
2
17
France
Voici l'erreur qui apparaît après le redémarrage alors que j'ai tout correctement effectué;
Screenshot_4.png


En sachant que j'ai tout bien effectué avec succès comme dans la configuration.
Maintenant ça affiche ça en jeu:
Screenshot_5.png

Code:
§f[§3SkyWorld§f]: Vous avez été §6soigné§f.
 

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
9 748
17
2 146
347
24
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

Avec quelle commande démarres-tu ton serveur ? Il faut que tu dise à Java que tu va lui donner de l'UTF-8 ;)
Je n'ai plus ça de tête mais cherche de ce côté la...

Vérifie également bien que le fichier est enregistré en UTF-8.


Cordialement,
Detobel36
 

Moutmoutéo

Staff manager et rédacteur
29 Mars 2020
4
0
2
17
France
Re-coucou ;),

Commande: sh run.sh
Le fichier et "fichier PROPERTIES" et on ne peut pas de mémoire changer cela.

Déjà chercher avant de venir sur un forum pour déranger tout le monde (surtout je sais que sa prend une année pour avoir une réponse parfois !)

- Matéo