Permissions  Plugin EssentialsXChat, GroupManager, le seul préfixe affiché est "default"

Discussion dans 'Support serveur et plugins' créé par GameBreaker01, 11 Mars 2018.

  1. GameBreaker01

    GameBreaker01 Nouveau

    Inscrit:
    11 Mars 2018
    Messages:
    4
    J'aime reçus:
    0
    Bonjour ! (ou Bonsoir, Bon appétit ça dépends)
    Depuis quelques temps j'ai décidé de créer un serveur Minecraft (1.12.2) pour pouvoir jouer entre potes. j'ai commencé avec vanilla, puis je suis arrivé sur bukkit... Car je voulais mieux administrer mon serveur vu qu'il commençais à y avoir du monde (en faisant des recherches j'ai trouvé le plugin groupmanager qui est très utilisé). J'ai installé ces plugins:
    EssentialsX, EssentialsXAntiBuild, EssentialsXChat, EssentialsXGroupManager, EssentialsXProtect, EssentialsXSpawn
    .
    Le tout avait l'air de fonctionner correctement ... Sauf que je me suis rendu compte que les préfixes que j'avais défini ne s'affichaient pas sur le chat. je suis donc aller modifier la partie essentialsChat le fichier config.yml du fichier Essentials. (j'ai enlevé le '#' devant les groupes sous la ligne 'group-formats:' et j'ai correctement (je pense) édité les lignes (pas d'accents, respect de l'indentation avec les espaces et non les tab ...)) j'ai vu une petite amélioration : à présent j'avais [default] qui s'affichait devant les nicknames, très bien... j'était content... Pendant 3 secondes... Car je me suis changé de groupe dans le groupe Fondateur, j'ai écris 'hello' et paf :il m'a affiché <[default] monpseudo> : hello , pourtant il semblait que les permissions fonctionnaient nickel, (là j'ai un petit doute vu que même quand je mettait 'true' pour 'build' pour le groupe par défaut, je ne pouvais pas poser ni détruire ni interagir, mais c'est encore un autre problème).Je pouvait néanmoins changer la couleur du [default] en rajoutant un couleur devant {GROUP} dans le fichier config. Bon après un éternité de recherche sur google et sur les forum, j'ai été amené à essayer énormément de choses comme : utliser sigpot pour le serveur, modifier en long en large et en travers les fichier en .yml, enlever GroupManager pour utiliser PermissionsEX (la c'était encore pire, les groupes était crèment ignorés) enfin bref... Je pense que vous avez compris je suis à bout, d'ou mon inscription sur le forum et ce post
    (je ne suis pas spécialement un fan de minecraft, j'y ai joué il y a longtemps (vers la 1.5) et j'ai eu envie d'y rejouer, évidemment je suis allé me compliquer l'histoire en voulant installer des plugins alors que j'aurais très bien pu rester sur Vanilla vous allez me dire, mais le mal est fait :p )

    Quand au fichier config.yml et ainsi que les autres, ce sont ceux par défault pour la version 2.0.1 d'Essentials. (car j'ai retéléchargé sigpot et j'ai relancé le serveur en supprimant l'ancien)

    Merci d'avance.
     
  2. Qwok_YT

    Qwok_YT Chameau à 6 bosses

    Inscrit:
    5 Janvier 2017
    Messages:
    255
    J'aime reçus:
    43
    Bonjour, d'après ce que j'ai vu au début tu as enlevé les "#" devant tous les exemples !
    Tu ne dois pas faire ça, et enlever le "#" seulement sur la forme de chat que tu veux.
    Tu peux mettre des accents, apostrophes (sous ce format ci: '' (ce ne sont pas des guillemets)) sans problème ni conflit.
    Tu es sûr que tu ne crée pas de grade à la place d'en donner ? Je m'explique; simplement, pour donner tes grades tu fais /manuadd Pseudo NomDuGrade ? Si ce n'est pas le cas, fait le ! :p
    Normalement, GroupManager est très facile à manipuler, sauf que parfois il y a plusieurs erreurs.
    Quand tu te mets un grade, ça écrit dans le chat "You were moved the group Fondateur in Monde" ?
    Est-ce que tu reçois parfois des messages "An internal error, ..." ?
     
  3. GameBreaker01

    GameBreaker01 Nouveau

    Inscrit:
    11 Mars 2018
    Messages:
    4
    J'aime reçus:
    0
    Désolé du retard j'ai eu un problème avec mon opérateur.
    Alors je n'avais pas enlevé le # devant tous les exemples. juste devant 'group-formats' , Et oui la commande est exécutée correctement (/manuadd Pseudo NomDuGrade) j'ai bien le message retour : "You were moved the group Fondateur in ..." Mais aucun changement niveau préfixe -_-
     
  4. Retr0p

    Retr0p Pianiste

    Inscrit:
    10 Décembre 2016
    Messages:
    153
    J'aime reçus:
    34

    Il faut ajouté le plugin vault et effectuer : "/mangaddv (nomdugroup) prefix (prefix)" exemple : /mangaddv Fondateur prefix &4Fondateur
     
  5. Qwok_YT

    Qwok_YT Chameau à 6 bosses

    Inscrit:
    5 Janvier 2017
    Messages:
    255
    J'aime reçus:
    43
    Pourquoi Vault ?
     
  6. Detobel36

    Detobel36 Créateur de plugins (PhoenixRebirth)
    Support

    Inscrit:
    17 Août 2012
    Messages:
    9 143
    J'aime reçus:
    1 935
    Salut,

    Parce que Vault permet à plusieurs plugins d'intégrer facilement l'économie, les permissions mais également le tchat.
    Cela dit, il ne me semble pas que Essentials ou GroupManager n'utilise Vault ;)

    Personnellement, j'ai du mal à t'aider @GameBreaker01 car jusqu'a présent nous n'avons eu que des explications mais rien de concret. Mes camarades ci-dessus on essayer d'apporter une aide sans vraiment savoir d'où venait exactement le problème.
    Je suis désolé mais pour moi, il faut être méthode quand on veut résoudre un problème.

    Je t'invite donc à poster ta liste de plugin, mais également ta configuration "groups.yml" (se trouvant dans le dossier plugins/GroupManager/world) ainsi que la partie de la configuration Essentials qui gère le tchat. Met tes configurations dans tes balises code pour qu'on puisse s'y retrouver;)


    Cordialement,
    Detobel36
     
    Qwok_YT apprécie ceci.
  7. GameBreaker01

    GameBreaker01 Nouveau

    Inscrit:
    11 Mars 2018
    Messages:
    4
    J'aime reçus:
    0
    Merci encore de votre aide.
    En effet je n'ai pas poster mes fichiers config et group car c'était ceux par défaut vu que j'avais tout supprimé. Mais depuis je les ai modifiés. Quand aux pulgins installé je les ai mis plus haut mais je vous les redonne : EssentialsX, EssentialsXAntiBuild, EssentialsXChat, EssentialsXGroupManager, EssentialsXProtect, EssentialsXSpawn et depuis peu j'ai installé Vault. Actuellement les préfixes dans le fichier groupe s'affichent très bien mais impossible d'éditer ça avec essentialChat
    groups.yml :
    Code:
    roups:
      Member:
        default: true
        permissions:
        - -bukkit.command.kill
        inheritance:
        - g:groupmanager_default
        - g:bukkit_default
        - g:essentials_default
        - g:towny_default
        info:
          prefix: '&7[member]&f '
          build: true
          suffix: ''
      Builder:
        default: false
        permissions: []
        inheritance:
        - default
        - g:essentials_builder
        - g:towny_builder
        info:
          prefix: '&2[Builder]&f '
          build: true
          suffix: ''
      Moderator:
        default: false
        permissions: []
        inheritance:
        - builder
        - g:groupmanager_moderator
        - g:bukkit_moderator
        - g:essentials_moderator
        - g:towny_moderator
        - g:vanish_moderator
        info:
          prefix: '&5[Moderator]&f '
          build: true
          suffix: ''
      Admin:
        default: false
        permissions: []
        inheritance:
        - moderator
        - g:groupmanager_admin
        - g:bukkit_admin
        - g:essentials_admin
        - g:towny_admin
        - g:vanish_admin
        info:
          prefix: '&c[Admin]&f '
          build: true
          suffix: ''
      Owner:
        default: false
        permissions:
        - '*'
        - -vanish.effects.*
        - +vanish.effects.toggle.all
        inheritance:
        - admin
        info:
          prefix: '&4[owner]&f '
          build: true
          suffix: ''
    
    EssentialChat :
    Code:
    chat:
    
      # If EssentialsChat is installed, this will define how far a player's voice travels, in blocks.  Set to 0 to make all chat global.
      # Note that users with the "essentials.chat.spy" permission will hear everything, regardless of this setting.
      # Users with essentials.chat.shout can override this by prefixing text with an exclamation mark (!)
      # Users with essentials.chat.question can override this by prefixing text with a question mark (?)
      # You can add command costs for shout/question by adding chat-shout and chat-question to the command costs section."
      radius: 0
    
      # Chat formatting can be done in two ways, you can either define a standard format for all chat.
      # Or you can give a group specific chat format, to give some extra variation.
      # For more information of chat formatting, check out the wiki: http://wiki.ess3.net/wiki/Chat_Formatting
      # For EssentialsX changes, take a look at the EssentialsX wiki: https://github.com/EssentialsX/Essentials/wiki
    
      format: '{DISPLAYNAME} say {MESSAGE}'
      #format: '&7[{GROUP}]&r {DISPLAYNAME}&7:&r {MESSAGE}'
      #format: '&7{PREFIX}&r {DISPLAYNAME}&r &7{SUFFIX}&r: {MESSAGE}'
    
      #group-formats:
        #Member: '{DISPLAYNAME}&7:&r {MESSAGE}'
        #Admin: '{WORLDNAME} &c[{GROUP}]&r {DISPLAYNAME}&7:&c {MESSAGE}'
        #owner: ' [Fondateur] &c[{GROUP}]&r {DISPLAYNAME}&7:&c {MESSAGE}'
    
      # If you are using group formats make sure to remove the '#' to allow the setting to be read.
    
    (bon j'avais tout essayé dans le fichier essentialChat, peut être pas assez, mais j'ai essayé)
     
  8. Detobel36

    Detobel36 Créateur de plugins (PhoenixRebirth)
    Support

    Inscrit:
    17 Août 2012
    Messages:
    9 143
    J'aime reçus:
    1 935
    Salut,

    Ok, pour ta liste de plugin, je n'avais pas compris que c'était aussi sommaire...

    Bon, tout d'abord pour ta configuration GroupManager, je vois que tu utilises des "globalGroup". Et vu que tu as laisser les GlobalGroup de plugin que tu n'utilises pas, je suppose que tu as juste laisser la configuration sans comprend à quoi ça servait... C'est pas une bonne idée, je t'invite à lire ce tutoriel: http://minecraft.fr/forum/index.php?threads/plugin-groupmanager.65981/

    Ensuite il y a quelques soucis avec tes inheritances. En effet, le groupe "Builder" a comme "inheritance" le groupe "default". Sauf que ce groupe n'existe pas.

    Ensuite, au niveau de tes préfixes tu peux tester ceci:
    Code:
      group-formats:
       Member: '&7[member]&f {DISPLAYNAME}: {MESSAGE}'
       Admin:  '&c[Admin]&f {DISPLAYNAME}: {MESSAGE}'
       owner: '&4[owner]&f {DISPLAYNAME}: {MESSAGE}'


    Cordialement,
    Detobel36[/code]
     
  9. GameBreaker01

    GameBreaker01 Nouveau

    Inscrit:
    11 Mars 2018
    Messages:
    4
    J'aime reçus:
    0
    En effet je n'avais pas touché à la config vu que je pensait que celle par défaut n'aurait pas posé de problème. Je savais à quoi servait les "globalGroup" (j'avais aussi déjà lu ton tuto ^^) mais j'y ai pas prêté attention, mais même en retirant laissant unsiquement les permissions d'essential et de groupmangaer, ça ne changer rien, et j'ai bien mis ce code du chat dans config.yml (en prenant soin de pas décommenter les autres lignes) pourtant toujours aucun effet, certes les préfixes s'affichent, mais de la façon dont je les ais configurés dans le fichier group, je sais pas trop d'où viens le problème sur ce coup là.
     

Partager cette page