Multijoueur Build JE CONVERTI VOS MAPS 1.14+ -> 1.13 et moins

Miryo

Nouveau
7 Février 2021
4
0
1
21
Bonjour, Bonsoir,

Je converti vos maps 1.14 et plus vers 1.13 et moins.

C’est quelque chose de normalement impossible (du à la nouvelle generation de map en 1.14 et plus) mais j’ai trouver une méthode efficace et sans perte de block (si vous etes un serveur modde vous n’aurez aucune perte de block, en vanilla vous en aurez (un texture pack peut y remedie)).

Vous pouvez me contacter en MP ou sous ce poste.
 
Dernière édition:

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 200
46
328
217
19
Mìlhüsa
Bonsoir,

Comment fais-tu exactement ?
C'est un peu complexe de downgrade une map car il faut enlever toutes les nouveautés et convertir les changements ; par exemple une jungle de bambous sans bambou semblera un peu bizarre, surtout que tu dois remplacer ce biome par un autre, et que si la jungle n'était qu'à moitié générée tu auras en plus la cassure du monde lors d'un changement de version, ce qui doit rendre le tout pas très esthétique.

D'autant plus si tu veux downgrade avant le flattening.

sans perdre de block (si vous etes un serveur modde)
Si tu parles de faire un mod qui réimplémente les fonctionnalités de la 1.14, je ne vois pas trop l'intérêt de jouer dans une version entre la 1.13 et la 1.14.
Et après si tu dis pouvoir downgrade une map moddé, ça me paraît difficilement réalisable.

Cordialement,
ShE3py
 

Miryo

Nouveau
7 Février 2021
4
0
1
21
Bonsoir,

Comment fais-tu exactement ?
C'est un peu complexe de downgrade une map car il faut enlever toutes les nouveautés et convertir les changements ; par exemple une jungle de bambous sans bambou semblera un peu bizarre, surtout que tu dois remplacer ce biome par un autre, et que si la jungle n'était qu'à moitié générée tu auras en plus la cassure du monde lors d'un changement de version, ce qui doit rendre le tout pas très esthétique.

D'autant plus si tu veux downgrade avant le flattening.


Si tu parles de faire un mod qui réimplémente les fonctionnalités de la 1.14, je ne vois pas trop l'intérêt de jouer dans une version entre la 1.13 et la 1.14.
Et après si tu dis pouvoir downgrade une map moddé, ça me paraît difficilement réalisable.

Cordialement,
ShE3py
Bonsoir, je préfère garder l’exclusivité de la technique.

Pour la map downgrade, sauf les blocks non existant rien ne change (downgrade d’une map 1.16 en 1.7 sans aucune perte)

Pour les serveurs moddés, j’ai un mod 1.7 -> 1.13 rajoutant les blocks de la 1.15
Les serveurs moddés n’auront donc aucune perte.

Cordialement
 

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 200
46
328
217
19
Mìlhüsa
Bonsoir, je préfère garder l’exclusivité de la technique.
Libre à toi de faire ce que tu veux, mais je précise juste que les règles générales du forum interdisent aux membres de proposer des services payants, donc tu ne peux pas demander de rémunération contre une conversion.

Pour la map downgrade, sauf les blocks non existant rien ne change (downgrade d’une map 1.16 en 1.7 sans aucune perte)
Je n'ai pas très bien compris si les blocs « non-existants » étaient censés représenter les blocs d'air ou les blocs qui n'existaient pas dans la version cible.
Dans le second cas, si tu les remplaces simplement par de l'air, ça revient à charger le monde normalement.

Pour les serveurs moddés, j’ai un mod 1.7 -> 1.13 rajoutant les blocks de la 1.15
Les serveurs moddés n’auront donc aucune perte.
Par serveur moddé j'entendais un serveur contenant des mods, et rien n'oblige ces mods à être présents dans la version cible. Donc en soit pas exemple pour convertir une map de la 1.14 à la 1.13, il faudrait que ces mods existent en 1.13.
Les mods ne peuvent généralement pas non plus être downgrade, donc il faudrait que ton mod rajoute aussi les blocs de ces mods, et là l'on peut rencontrer des problèmes de droit d'auteur.

Après la question que je me pose c'est quel est l'intérêt de vouloir jouer en 1.7 avec un mod qui rajoute des blocs de la 1.15 alors qu'on pourrait jouer en 1.15.
Puis comme dit, il faudrait aussi que le mod rajoute les biomes, les créatures, etc.
 

Miryo

Nouveau
7 Février 2021
4
0
1
21
Libre à toi de faire ce que tu veux, mais je précise juste que les règles générales du forum interdisent aux membres de proposer des services payants, donc tu ne peux pas demander de rémunération contre une conversion.


Je n'ai pas très bien compris si les blocs « non-existants » étaient censés représenter les blocs d'air ou les blocs qui n'existaient pas dans la version cible.
Dans le second cas, si tu les remplaces simplement par de l'air, ça revient à charger le monde normalement.


Par serveur moddé j'entendais un serveur contenant des mods, et rien n'oblige ces mods à être présents dans la version cible. Donc en soit pas exemple pour convertir une map de la 1.14 à la 1.13, il faudrait que ces mods existent en 1.13.
Les mods ne peuvent généralement pas non plus être downgrade, donc il faudrait que ton mod rajoute aussi les blocs de ces mods, et là l'on peut rencontrer des problèmes de droit d'auteur.

Après la question que je me pose c'est quel est l'intérêt de vouloir jouer en 1.7 avec un mod qui rajoute des blocs de la 1.15 alors qu'on pourrait jouer en 1.15.
Puis comme dit, il faudrait aussi que le mod rajoute les biomes, les créatures, etc.
Les blocks non existants disparaitront
Un monde 1.14 est impossible à charger en 1.13 (essaye tu verras bien)
Un serveur moddés, pourra utiliser mon mod afin d’avoir les blocks de la 1.15.2 en 1.13 et moins
Je ne downgrade pas les mods