Plugin faction marqué non a jour alors que c a jour

Syxpi_Kill3r

Aventurier
15 Avril 2021
16
0
1
28
Bonjour, j'ai remarqué que mon serveur en 1.9.4 fonctionnait pas très bien, surtout le plugin faction, quand je regarde dans ma console, sa me met que le plugin est pas a jour,sauf que la dernière version connue de ce plugin est la 2.14.0,Or, Massive core et Factions sont sous la version 2.14.0, donc y'as un sacré problème,Je vais vous envoyer des screens pour prouver ceci, parce que la j'comprend rien,si faut mettre les logs,merci de me le dire, comme on peut le voir sur le premier screen, quand on fait help factions, rien s'affiche, Qui en plus, Massive core et Factions sont en vert, donc la y'as un bug quelque part ,sur le 2eme screen, Factions est en 2.14.0 mais ne charge pas, sur le 3eme, on voit bien que Massive core c la meme chose, et sur le 4ème et 5ème, on voit la version des plugins en question
Merci de m'aider parce que la j'croit juste que je vais péter un cable, ce serveur a eu tellement de bugs et autre
 

Fichiers joints

  • Screenshot_2.jpg
    Screenshot_2.jpg
    199 KB · Affichages: 155
  • Screenshot_3.jpg
    Screenshot_3.jpg
    19.5 KB · Affichages: 158
  • Screenshot_6.jpg
    Screenshot_6.jpg
    59 KB · Affichages: 143
  • Screenshot_4.jpg
    Screenshot_4.jpg
    7.3 KB · Affichages: 139
  • Screenshot_5.jpg
    Screenshot_5.jpg
    8.2 KB · Affichages: 137

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
10 530
24
2 247
347
27
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

Peux tu nous donner les logs complet plutôt que des screens où il manque les informations importante pour comprendre le soucis ;) (c'est possible que pour toi ça ne veut rien dire mais pour un développeur, les lignes en dessous des messages d'erreur sont très intéressante).


Cordialement,
Detobel36
 

Syxpi_Kill3r

Aventurier
15 Avril 2021
16
0
1
28
Salut,

Peux tu nous donner les logs complet plutôt que des screens où il manque les informations importante pour comprendre le soucis ;) (c'est possible que pour toi ça ne veut rien dire mais pour un développeur, les lignes en dessous des messages d'erreur sont très intéressante).


Cordialement,
Detobel36
j'envoie le latest.log?, si c'est le latest qui faut, je l'envoie
 

Fichiers joints

  • latest.log
    88 KB · Affichages: 126
Dernière édition:

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
10 530
24
2 247
347
27
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

Bon alors déjà:
Code:
[05:00:48] [Server thread/ERROR]: Ambiguous plugin name `LuckPerms' for files `plugins/LuckPerms.jar' and `plugins/LuckPerms-Bungee-5.3.16.jar' in `plugins'
Pourquoi mettre "LuckPerms-Bungee" dans le dossier "plugins" du spigot. C'est un plugin pour bungeecord uniquement ;)

Je vois également que tu as installé "EssentialsGeoIP" et "EssentialsXMPP" sais-tu au moins à quoi ça sert ?
Si la réponse est "non", c'est que tu n'en a pas besoin.

Tu as une erreur dans la config de "SafeTrade":
Code:
[05:01:06] [Server thread/ERROR]: Cannot load plugins/SafeTrade/config.yml
org.bukkit.configuration.InvalidConfigurationException: while scanning a simple key
in 'string', line 40, column 1:
    maxTradingDistance:-1
    ^
could not find expected ':'
in 'string', line 41, column 1:
    ################################ ...
    ^
Ligne 40

Tu as également une erreur avec GUIShop.
Code:
[05:01:07] [Server thread/ERROR]: Error occurred while enabling GUIShop v8.5 (Is it up to date?)
java.lang.NullPointerException
    at org.bukkit.inventory.ItemStack.<init>(ItemStack.java:68) ~[spigot1.9.4.jar:git-Spigot-c6871e2-0cd0397]
Soit c'est une erreur de configuration, soit c'est une erreur dans le code (il faut voir si le développeur n'a pas fait une mise à jour ou donner des infos à ce sujet).

Le plugin "UltimateKits" semble également ne pas correspondre à ta version de spigot (je pense que tu dois prendre une version antérieur du plugin).


Pour le problème avec Faction, peux-tu aller dans le fichier mstore/massivecore_mconf/instance.json
Et regarder s'il y a un paramètre "debugWriters".
Si ce paramètre n'existe pas, fait une sauvegarde du dossier "mstore" et supprime le (après l'avoir sauvegardé du coup ;) ).
Si le paramètre existe, essaye de le mettre à "true".


Cordialement,
Detobel36
 

Syxpi_Kill3r

Aventurier
15 Avril 2021
16
0
1
28
Salut,

Bon alors déjà:
Code:
[05:00:48] [Server thread/ERROR]: Ambiguous plugin name `LuckPerms' for files `plugins/LuckPerms.jar' and `plugins/LuckPerms-Bungee-5.3.16.jar' in `plugins'
Pourquoi mettre "LuckPerms-Bungee" dans le dossier "plugins" du spigot. C'est un plugin pour bungeecord uniquement ;)

Je vois également que tu as installé "EssentialsGeoIP" et "EssentialsXMPP" sais-tu au moins à quoi ça sert ?
Si la réponse est "non", c'est que tu n'en a pas besoin.

Tu as une erreur dans la config de "SafeTrade":
Code:
[05:01:06] [Server thread/ERROR]: Cannot load plugins/SafeTrade/config.yml
org.bukkit.configuration.InvalidConfigurationException: while scanning a simple key
in 'string', line 40, column 1:
    maxTradingDistance:-1
    ^
could not find expected ':'
in 'string', line 41, column 1:
    ################################ ...
    ^
Ligne 40

Tu as également une erreur avec GUIShop.
Code:
[05:01:07] [Server thread/ERROR]: Error occurred while enabling GUIShop v8.5 (Is it up to date?)
java.lang.NullPointerException
    at org.bukkit.inventory.ItemStack.<init>(ItemStack.java:68) ~[spigot1.9.4.jar:git-Spigot-c6871e2-0cd0397]
Soit c'est une erreur de configuration, soit c'est une erreur dans le code (il faut voir si le développeur n'a pas fait une mise à jour ou donner des infos à ce sujet).

Le plugin "UltimateKits" semble également ne pas correspondre à ta version de spigot (je pense que tu dois prendre une version antérieur du plugin).


Pour le problème avec Faction, peux-tu aller dans le fichier mstore/massivecore_mconf/instance.json
Et regarder s'il y a un paramètre "debugWriters".
Si ce paramètre n'existe pas, fait une sauvegarde du dossier "mstore" et supprime le (après l'avoir sauvegardé du coup ;) ).
Si le paramètre existe, essaye de le mettre à "true".


Cordialement,
Detobel36
euh wtf, la dernière fois que j'ai verif, y'avait pas luckperms bungeecord, Guishop, aucune erreur dessus, et EssentialsSMPP et EssentialsGeoIP se sont download automatiquement avec EssentialsX,UltimateKits marche parfaitement, donc pas besoin de le changer, Et safetrade aussi, mais GUIShop j'vais le virer de toute facon
et je regarde dans 5min pour le problème avec le plugin faction
Edit:Une fois le paramètre mis a true, tjr rien
 
Dernière édition:

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
10 530
24
2 247
347
27
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

Edit:Une fois le paramètre mis a true, tjr rien
"toujours rien" mais également "rien" dans les logs ?

aucune erreur dessus
Bah si, y a pleins d'erreur dans tes logs.

C'est pas parce qu'un plugin fonctionne comme tu le pense que tout va bien... C'est un peu comme si tu amènes ta voiture chez le garagiste, qu'il te dit qu'il y a des trucs à changer/réparer et toi tu fait "bah ça roule non ? Alors je continue !".

Y a parfois des incompatibilités entre les plugins. Et régler un soucis permet de mieux voir un autre problème et de régler le deuxième. M'enfin bon, si tu veux pas suivre les conseils donné, c'est ton choix.


Cordialement,
Detobel36
 

Syxpi_Kill3r

Aventurier
15 Avril 2021
16
0
1
28
Salut,


"toujours rien" mais également "rien" dans les logs ?


Bah si, y a pleins d'erreur dans tes logs.

C'est pas parce qu'un plugin fonctionne comme tu le pense que tout va bien... C'est un peu comme si tu amènes ta voiture chez le garagiste, qu'il te dit qu'il y a des trucs à changer/réparer et toi tu fait "bah ça roule non ? Alors je continue !".

Y a parfois des incompatibilités entre les plugins. Et régler un soucis permet de mieux voir un autre problème et de régler le deuxième. M'enfin bon, si tu veux pas suivre les conseils donné, c'est ton choix.


Cordialement,
Detobel36
pour factions, y'as toujours l'erreur (up to date)
Et si j'veut utiliser des plugins cassées, j'utilise ces plugins, c'est tout
 

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
10 530
24
2 247
347
27
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

pour factions, y'as toujours l'erreur (up to date)
Ce n'est pas ça qui compte mais l'erreur qui il y a en dessous.
Surtout que c'est une "supposition" de Spigot de dire que le plugin n'est pas à jour ;) Il ne dit pas que le soucis c'est un problème de mise à jour.

Et si j'veut utiliser des plugins cassées, j'utilise ces plugins, c'est tout
Bien sûr mais ne compte plus trop sur moi dans ce cas la :D


Cordialement,
Detobel36