Recherche Idée Plugin Utilisation permissions

Max.dety90

Fondateur du serveur Amnesia
30 Avril 2021
37
2
19
16
Nice
Salut,


Luckperms gère les permissions standard spigot/bukkit/paper.
Donc si, je te confirme que ça gère bien ça. Tu as du faire une erreur quelque part.

Peux-tu me décrire ce que tu fais et où ça bloque ?


Cordialement,
Detobel36
Alors là actuellement les visiteurs peuvent interagir avec tous les blocs (appuyer sur des boutons, presser des planches de détections ouvrir des portes bref tout)

ce n'est pas ce que je veux moi

Je veux juste qu'ils aient accès aux planches de pression moi rien d'autre

Salut,


N'importe quel plugin de permission:
  • Luck perm
  • GroupManage
  • PermissionsEx
  • ...
Tous les plugins de permissions se base sur un outil donné par bukkit/spigot/paper/... Donc n'importe quel plugin de permission digne de ce nom sera bon.


Cordialement,
Detobel36
en faisant la commande /region flag global use deny plus rien n'est accessible, mais je voudrais que seuls les planches d'interactions le soient
 
Dernière édition par un modérateur:

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
10 471
24
2 240
347
26
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

Bon déjà il faut savoir que les "double poste" (le fait de poster un message après son propre message) est interdit. Tu dois utiliser le bouton "Editer". On est pas sur un tchat ici.

Et j'ai bien compris ton problème. Je t'ai dit qu'il était possible, pour un module complet de bloquer cette interaction en utilisant un plugin de permission.
La commande "/region" c'est WorldGuard. Rien avoir avec les permissions.

Pour pouvoir t'aider, il faut que tu me dises à quel moment tu n'arrives pas à entrer les permissions créé par EssentialsAntiBuild.

Si tu as LuckPerm, normalement tu as juste à faire ces deux commandes:
Code:
/lp group <nom du group> permission set essentials.build.interact.* false
/lp group <nom du group> permission set essentials.build.interact.OAK_BUTTON true
La première permet de "supprimer la permission" d'interagir avec tout. Et la seconde donne la permission d'interagir avec

Tu as la liste des blocks ici: https://hub.spigotmc.org/javadocs/spigot/org/bukkit/Material.html
Attention que le button en bois "simple" n'est pas le même que le bouton en bois de la jungle, bouleau...


Cordialement,
Detobel36
 

Max.dety90

Fondateur du serveur Amnesia
30 Avril 2021
37
2
19
16
Nice
Salut,

Bon déjà il faut savoir que les "double poste" (le fait de poster un message après son propre message) est interdit. Tu dois utiliser le bouton "Editer". On est pas sur un tchat ici.

Et j'ai bien compris ton problème. Je t'ai dit qu'il était possible, pour un module complet de bloquer cette interaction en utilisant un plugin de permission.
La commande "/region" c'est WorldGuard. Rien avoir avec les permissions.

Pour pouvoir t'aider, il faut que tu me dises à quel moment tu n'arrives pas à entrer les permissions créé par EssentialsAntiBuild.

Si tu as LuckPerm, normalement tu as juste à faire ces deux commandes:
Code:
/lp group <nom du group> permission set essentials.build.interact.* false
/lp group <nom du group> permission set essentials.build.interact.OAK_BUTTON true
La première permet de "supprimer la permission" d'interagir avec tout. Et la seconde donne la permission d'interagir avec

Tu as la liste des blocks ici: https://hub.spigotmc.org/javadocs/spigot/org/bukkit/Material.html
Attention que le button en bois "simple" n'est pas le même que le bouton en bois de la jungle, bouleau...


Cordialement,
Detobel36
Salut, veuillez m'excusez je n'ai pas lu le règlement, encore désolé, je croyais qu'il fallait mettre les permissions via le /lp editor et non directement sur le jeu. J'ai fait donc la commande que vous m'avez inscrit précédemment et voilà que maintenant le message est : "Hey Sorry but you can't use that here
 
Dernière édition:

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
10 471
24
2 240
347
26
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

Salut, veuillez m'excusez je n'ai pas lu le règlement, encore désolé, je croyais qu'il fallait mettre les permissions via le /lp editor et non directement sur le jeu. J'ai fait donc la commande que vous m'avez inscrit précédemment et voilà que maintenant le message est : "Hey Sorry but you can't use that here
Tu peux aussi le faire via l'editor. Juste que c'est plus compliqué à expliqué par message...

voilà que maintenant le message est : "Hey Sorry but you can't use that here
Tu as ça quand tu fais la commande ? Ou quand un joueur veut interagir ?
Si tu veux de l'aide, faut nous donner des infos ;) Nous on ne connait que ce que tu nous donnes comme informations.


Cordialement,
Detobel36
 

Max.dety90

Fondateur du serveur Amnesia
30 Avril 2021
37
2
19
16
Nice
Salut,


Tu peux aussi le faire via l'editor. Juste que c'est plus compliqué à expliqué par message...


Tu as ça quand tu fais la commande ? Ou quand un joueur veut interagir ?
Si tu veux de l'aide, faut nous donner des infos ;) Nous on ne connait que ce que tu nous donnes comme informations.


Cordialement,
Detobel36
D'accord pas de souci, je reçois ce message dès que j'interagis et non quand je fais la commande
 

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
10 471
24
2 240
347
26
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

D'accord pas de souci, je reçois ce message dès que j'interagis et non quand je fais la commande
Le message que tu donnes la, c'est WorldGuard... Evidemment, si tu gères les "accès" avec les permissions, tu dois supprimer les protections WorldGuard...

Il faut "comprendre" ce que tu fais ;)


Cordialement,
Detobel36
 

Max.dety90

Fondateur du serveur Amnesia
30 Avril 2021
37
2
19
16
Nice
Salut,


Le message que tu donnes la, c'est WorldGuard... Evidemment, si tu gères les "accès" avec les permissions, tu dois supprimer les protections WorldGuard...

Il faut "comprendre" ce que tu fais ;)


Cordialement,
Detobel36
et la commande pour ce faire c'est laquelle ?
 

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
10 471
24
2 240
347
26
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

et la commande pour ce faire c'est laquelle ?
Pour faire quoi ? Désactiver WorldGuard ?
Ca dépend ce que tu as activé...

Fait un /rg info <nom de ta region> et voit les flag qui bloquent...
Limite, supprime la région si tu l'utilisait juste pour "bloquer" ça.

Comme je l'ai dit, "comprend" ce que tu fais. Comprend comment les permissions et WorldGuard fonctionne. Pour ça, il faut lire/regarder des tuto plugin par plugin ;)


Cordialement,
Detobel36
 

Max.dety90

Fondateur du serveur Amnesia
30 Avril 2021
37
2
19
16
Nice
Salut,

Bon déjà il faut savoir que les "double poste" (le fait de poster un message après son propre message) est interdit. Tu dois utiliser le bouton "Editer". On est pas sur un tchat ici.

Et j'ai bien compris ton problème. Je t'ai dit qu'il était possible, pour un module complet de bloquer cette interaction en utilisant un plugin de permission.
La commande "/region" c'est WorldGuard. Rien avoir avec les permissions.

Pour pouvoir t'aider, il faut que tu me dises à quel moment tu n'arrives pas à entrer les permissions créé par EssentialsAntiBuild.

Si tu as LuckPerm, normalement tu as juste à faire ces deux commandes:
Code:
/lp group <nom du group> permission set essentials.build.interact.* false
/lp group <nom du group> permission set essentials.build.interact.OAK_BUTTON true
La première permet de "supprimer la permission" d'interagir avec tout. Et la seconde donne la permission d'interagir avec

Tu as la liste des blocks ici: https://hub.spigotmc.org/javadocs/spigot/org/bukkit/Material.html
Attention que le button en bois "simple" n'est pas le même que le bouton en bois de la jungle, bouleau...


Cordialement,
Detobel36
ça y est cela fonctionne merci pour tout vraiment et encore désolé
 
  • J'aime
Reactions: Detobel36