Configuration Problème avec le proxy Waterfall/Bungee

dylandt1

Nouveau
11 Juin 2020
4
0
1
20
Bonjour/Bonsoir,

Tout d'abord si mon problème a déjà été vu/corrigé, je tiens a m'excuser.

Donc mon problème est très embêtant et je ne comprend pas vraiment d'où il proviens, je m’explique. J'ai décider de créer un serveur minecraft sous sponge 1.12.2 mais avant d'engendrer des frais de serveur j'ai préférer l'installer sur un vieux poweredge r220 que j'ai chez moi, j'utilise donc Waterfall en tant que proxy, mais ce dernier est incapable tout comme bungeecord de se connecter au seul serveur actuellement en ligne a savoir le lobby, par contre le lobby lui est directement accessible depuis son ip et son port, cela vas faire 3 jours que je cherche une solution en vain.

PS: mes ports sont ouverts sur la box vue que le serveur est actuellement placé en DMZ et ne bloque littéralement aucuns ports de même pour le firewall, ok c'est pas ouf niveau sécurité mais j'ai tenté le tout pour le tout mais même avec tout les ports possibles et inimaginables ouverts, le proxy est toujours incapable de se connecter au serveur.

Voici la config du proxy:

prevent_proxy_connections: false
listeners:
- query_port: 25577
motd: '&1Another Bungee server'
tab_list: GLOBAL_PING
query_enabled: false
proxy_protocol: false
forced_hosts:
play.domaine.fr: lobby
ping_passthrough: false
priorities:
- lobby
bind_local_address: true
host: 0.0.0.0:25565
max_players: 10
tab_size: 60
force_default_server: true
remote_ping_cache: -1
network_compression_threshold: 256
permissions:
default:
- bungeecord.command.server
- bungeecord.command.list
admin:
- bungeecord.command.alert
- bungeecord.command.end
- bungeecord.command.ip
- bungeecord.command.reload
log_pings: true
connection_throttle_limit: 3
server_connect_timeout: 5000
timeout: 30000
player_limit: 10
ip_forward: true
groups:
Player:
- admin
remote_ping_timeout: 5000
connection_throttle: 4000
log_commands: false
stats: 6e64d8ae-6c2a-49d1-a767-20fece028d18
online_mode: true
forge_support: true
disabled_commands:
- disabledcommandhere
servers:
lobby:
motd: '&4Mon motd!'
address: localhost:25561
restricted: false
srv1:
motd: '&1Mon motd!'
address: localhost:25562
restricted: false

Je vous remercie par avance de votre aide.
 
Dernière édition:

dylandt1

Nouveau
11 Juin 2020
4
0
1
20
:up:

Le pire est que maintenant le proxy affiche le MOTD du lobby ainsi que le nombre de joueurs du lobby mais refuse toujours de s'y connecter.
Message reçu : ReadTimeoutException : null

Je vous remercie par avance de votre aide.
 

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
9 743
17
2 143
347
24
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

D'abord, la prochaine fois utilise les balises "code" pour mettre des configurations ou des logs.

par contre le lobby lui est directement accessible depuis son ip et son port, cela vas faire 3 jours que je cherche une solution en vain.
Je suppose que ça c'est quand tu met "modules.bungeecord" à False dans ton config/sponge/global.conf...


Ensuite, que je comprennes bien...
Tous les serveurs dont tu parles sont hébergés chez toi ? Donc tu arrives à te connecter au serveur sponge de manière direct mais pas à waterfall ?
Tu as l'erreur "ReadTimeoutException" dans les logs waterfall et rien dans les logs du serveur sponge quand tu essayes de te connecter ?


Cordialement,
Detobel36