Mod Résolu Problème Blocs Serveur Moddé Forge 1.12.2

Parzivalxx

Poseur de cobblestone
23 Août 2018
48
2
23
25
minecraft_server.1.12.2.jar est justement le serveur vanilla, et le forge-version-universal.jar est le serveur moddé. Le serveur vanilla est présent car Forge a besoin de lui.

Envois les logs du serveur forge qui ne veut pas se lancer, car là tu lances un serveur vanilla et c'est normal qu'il bloque les mods.

Finalement,j'ai lancé le fichier forge-truc-machin-universal.jar,alors,clairement,il me dit que tout marche sauf le client,que je n'ai pas la version demandée,je suis désolé,mais je ne peut pas t'envoyer une capture d'écran ni une copie avec des lettres car il y en as tellement...

Maintenant,du coup,le problème,c'est moi !!
 

Parzivalxx

Poseur de cobblestone
23 Août 2018
48
2
23
25
Tiens,je t'envoie le fichier debug qui a été réalisé,dis-moi ce que tu en penses.

Je crois avoir compris qu'il me dit qu'il n'arrive pas à trouver le "core mod" pour tous les mods mais qu'il a trouvé les "core mod" fondamentaux
 

Fichiers joints

  • debug.log
    2.9 Mo · Affichages: 269

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 510
58
355
247
20
Mìlhüsa
il me dit que tout marche sauf le client
Je peux pas deviner ce qu'il te dit.

que je n'ai pas la version demandée
Il faut que le client et le serveur aient les mêmes versions des mods, et une version compatible avec Forge.

je ne peut pas t'envoyer une capture d'écran ni une copie avec des lettres car il y en as tellement
Si le fichier lasted.log est trop grand, envoie-le en pièce jointe.

Tiens,je t'envoie le fichier debug qui a été réalisé,dis-moi ce que tu en penses.
Les logs en debug sont utiles dans certains cas, car il indique TOUT ce qu'il fait et que ça génère des fichiers énormes, alors que même sans être en debug il indique les erreurs qu'il rencontre.

Comme dit, il indique qu'il a refusé ta connexion :
Code:
[16:20:55] [Netty Server IO #4/INFO] [FML]: Client attempting to join with 4 mods : [email protected],[email protected],[email protected],[email protected]
[16:20:55] [Netty Server IO #4/INFO] [FML]: Attempting connection with missing mods [micdoodlecore, securitycraft, bibliocraft, brandonscore, cfm, codechickenlib, cofhcore, cofhworld, draconicevolution, enderio, enderiobase, enderioconduits, enderioconduitsappliedenergistics, enderioconduitsopencomputers, enderioconduitsrefinedstorage, enderiointegrationforestry, enderiointegrationtic, enderiointegrationticlate, enderiomachines, enderiopowertools, endercore, flansmodapocalypse, flansmod, galacticraftplanets, galacticraftcore, hammercore, ironchest, mekanism, mekanismgenerators, redstoneflux, rftools, simplyjetpacks, solarflux, thermaldynamics, thermalexpansion, thermalfoundation, worldedit] at CLIENT
[16:20:55] [Netty Server IO #4/INFO] [FML]: Rejecting connection CLIENT: BiblioCraft: Requires version 2.4.5 but mod is not found on client.
Brandon's Core: Requires version 2.4.4 but mod is not found on client.
CoFH Core: Requires version 4.5.3 but mod is not found on client.
CoFH World: Requires version 1.2.0 but mod is not found on client.
CodeChicken Lib: Requires version 3.2.1.351 but mod is not found on client.
Draconic Evolution: Requires version 2.3.13 but mod is not found on client.
Ender IO: Requires version 5.0.25 but mod is not found on client.
Ender IO Applied Energistics Conduits: Requires version 5.0.25 but mod is not found on client.
Ender IO Base: Requires version 5.0.25 but mod is not found on client.
Ender IO Conduits: Requires version 5.0.25 but mod is not found on client.
Ender IO Integration with Forestry: Requires version 5.0.25 but mod is not found on client.
Ender IO Integration with Tinkers' Construct: Requires version 5.0.25 but mod is not found on client.
Ender IO Integration with Tinkers' Construct: Requires version 5.0.25 but mod is not found on client.
Ender IO Machines: Requires version 5.0.25 but mod is not found on client.
Ender IO Open Computers Conduits: Requires version 5.0.25 but mod is not found on client.
Ender IO Powertools: Requires version 5.0.25 but mod is not found on client.
Ender IO Refined Storage Conduits: Requires version 5.0.25 but mod is not found on client.
EnderCore: Requires version 1.12.2-0.5.37 but mod is not found on client.
Flan's Mod: Requires version range @[email protected] but mod is not found on client.
Flan's Mod: Apocalypse: Requires version 1.0 or above, and below 1.1 but mod is not found on client.
Galacticraft Core: Requires version 4.0.1.181 but mod is not found on client.
Galacticraft Planets: Requires version 4.0.1.181 but mod is not found on client.
Hammer Core: Requires version 2.0.2.2 but mod is not found on client.
Iron Chest: Requires version 1.12.2-7.0.40.824 but mod is not found on client.
Mekanism: Requires version 1.12.2-9.4.13.349 but mod is not found on client.
MekanismGenerators: Requires version 9.4.11 but mod is not found on client.
MrCrayfish's Furniture Mod: Requires version 5.6.1 but mod is not found on client.
RFTools: Requires version 6.12 but mod is not found on client.
Redstone Flux: Requires version 2.0.2 but mod is not found on client.
SecurityCraft: Requires version v1.8.6 but mod is not found on client.
Simply Jetpacks 2: Requires version 2.2.6.43 but mod is not found on client.
Solar Flux Reborn: Requires version 4.10r but mod is not found on client.
Thermal Dynamics: Requires version 2.5.1 but mod is not found on client.
Thermal Expansion: Requires version 5.5.0 but mod is not found on client.
Thermal Foundation: Requires version 2.5.0 but mod is not found on client.
À la ligne 22 034 (vive le debug). C'est assez parlant : le client n'a pas tous les mods (il dit même la version requise).

Et sinon, penses au bouton "éditer" au lieu de poster deux messages à la suite.

P.S: Tant que j'y pense, as-tu bien un bouton "Mods" sur le menu principale de ton minecraft ?
 
Dernière édition:

Parzivalxx

Poseur de cobblestone
23 Août 2018
48
2
23
25
Je peux pas deviner ce qu'il te dit.


Il faut que le client et le serveur aient les mêmes versions des mods, et une version compatible avec Forge.


Si le fichier lasted.log est trop grand, envoie-le en pièce jointe.


Les logs en debug sont utiles dans certains cas, car il indique TOUT ce qu'il fait et que ça génère des fichiers énormes, alors que même sans être en debug il indique les erreurs qu'il rencontre.

Comme dit, il indique qu'il a refusé ta connexion :
Code:
[16:20:55] [Netty Server IO #4/INFO] [FML]: Client attempting to join with 4 mods : [email protected],[email protected],[email protected],[email protected]
[16:20:55] [Netty Server IO #4/INFO] [FML]: Attempting connection with missing mods [micdoodlecore, securitycraft, bibliocraft, brandonscore, cfm, codechickenlib, cofhcore, cofhworld, draconicevolution, enderio, enderiobase, enderioconduits, enderioconduitsappliedenergistics, enderioconduitsopencomputers, enderioconduitsrefinedstorage, enderiointegrationforestry, enderiointegrationtic, enderiointegrationticlate, enderiomachines, enderiopowertools, endercore, flansmodapocalypse, flansmod, galacticraftplanets, galacticraftcore, hammercore, ironchest, mekanism, mekanismgenerators, redstoneflux, rftools, simplyjetpacks, solarflux, thermaldynamics, thermalexpansion, thermalfoundation, worldedit] at CLIENT
[16:20:55] [Netty Server IO #4/INFO] [FML]: Rejecting connection CLIENT: BiblioCraft: Requires version 2.4.5 but mod is not found on client.
Brandon's Core: Requires version 2.4.4 but mod is not found on client.
CoFH Core: Requires version 4.5.3 but mod is not found on client.
CoFH World: Requires version 1.2.0 but mod is not found on client.
CodeChicken Lib: Requires version 3.2.1.351 but mod is not found on client.
Draconic Evolution: Requires version 2.3.13 but mod is not found on client.
Ender IO: Requires version 5.0.25 but mod is not found on client.
Ender IO Applied Energistics Conduits: Requires version 5.0.25 but mod is not found on client.
Ender IO Base: Requires version 5.0.25 but mod is not found on client.
Ender IO Conduits: Requires version 5.0.25 but mod is not found on client.
Ender IO Integration with Forestry: Requires version 5.0.25 but mod is not found on client.
Ender IO Integration with Tinkers' Construct: Requires version 5.0.25 but mod is not found on client.
Ender IO Integration with Tinkers' Construct: Requires version 5.0.25 but mod is not found on client.
Ender IO Machines: Requires version 5.0.25 but mod is not found on client.
Ender IO Open Computers Conduits: Requires version 5.0.25 but mod is not found on client.
Ender IO Powertools: Requires version 5.0.25 but mod is not found on client.
Ender IO Refined Storage Conduits: Requires version 5.0.25 but mod is not found on client.
EnderCore: Requires version 1.12.2-0.5.37 but mod is not found on client.
Flan's Mod: Requires version range @[email protected] but mod is not found on client.
Flan's Mod: Apocalypse: Requires version 1.0 or above, and below 1.1 but mod is not found on client.
Galacticraft Core: Requires version 4.0.1.181 but mod is not found on client.
Galacticraft Planets: Requires version 4.0.1.181 but mod is not found on client.
Hammer Core: Requires version 2.0.2.2 but mod is not found on client.
Iron Chest: Requires version 1.12.2-7.0.40.824 but mod is not found on client.
Mekanism: Requires version 1.12.2-9.4.13.349 but mod is not found on client.
MekanismGenerators: Requires version 9.4.11 but mod is not found on client.
MrCrayfish's Furniture Mod: Requires version 5.6.1 but mod is not found on client.
RFTools: Requires version 6.12 but mod is not found on client.
Redstone Flux: Requires version 2.0.2 but mod is not found on client.
SecurityCraft: Requires version v1.8.6 but mod is not found on client.
Simply Jetpacks 2: Requires version 2.2.6.43 but mod is not found on client.
Solar Flux Reborn: Requires version 4.10r but mod is not found on client.
Thermal Dynamics: Requires version 2.5.1 but mod is not found on client.
Thermal Expansion: Requires version 5.5.0 but mod is not found on client.
Thermal Foundation: Requires version 2.5.0 but mod is not found on client.
À la ligne 22 034 (vive le debug). C'est assez parlant : le client n'a pas tous les mods (il dit même la version requise).

Et sinon, penses au bouton "éditer" au lieu de poster deux messages à la suite.

Oui,tu as raison,je devrais y penser,merci de me le rappeler ^^

Bref,blague a part,je suis un idiot !!

Quand j'ai voulu rejoindre le serveur,je n'avais AUCUN mod chargé.

Donc,clairement,
CA MARCHE !!!!!!!!!!!!!!!!!!!!!!!!!!


Maintenant,j'ai le problème des lags à régler.

Je vous remercie tous les deux pour m'avoir aidé durant tout ce temps ^^

Mais,comme je l'ai dis auparavant,j'ai les lags.
Sérieux,pourquoi es-ce que ça existe cette saleté ??
 
  • J'aime
Reactions: blackeyes25

Helios_38

Nouveau
23 Mars 2020
1
0
1
21
Bonjour j'ai également un problème avec minecrfat 1.7.10 défense tech fait crash forge voici le crash report.
 

Fichiers joints

  • crash-2020-03-23_17.20.02-client.txt
    8.7 KB · Affichages: 109