Plugin Problème de compatibilité entre Faction et WorldGuard !

ddzouille0202

Cueilleur de roses
6 Janvier 2017
23
0
14
24
Bonjours à toutes et à tous, je fait un message vite fait car j'ai un problème en sois pas gênant mais qui le devient. Je suis en développement d'un serveur pvp-faction en 1.8.x/1.9.x/1.10.x/1.11.x/1.12.x. J'ai le plugin factions qui fonctionne sans problème. Et le plugin WorldGuard de même. Sauf que sa me spam une erreur dans la console et impossible d'utiliser les flag faction sur worldguard. !

Merci d'avance pour l'aide que vous pourrez me fournir !
PS: Je m'excuse pour toutes fautes !

Erreur de la console :

[21:57:48] [Server thread/WARN]: at com.massivecraft.factions.integration.worldguard.EngineWorldGuard.get(EngineWorldGuard.java:32)
[21:57:48] [Server thread/WARN]: at com.massivecraft.factions.integration.worldguard.IntegrationWorldGuard.getEngine(IntegrationWorldGuard.java:26)
[21:57:48] [Server thread/WARN]: at com.massivecraft.massivecore.Integration.getEngines(Integration.java:102)
[21:57:48] [Server thread/WARN]: at com.massivecraft.massivecore.Integration.setIntegrationActiveEngines(Integration.java:93)
[21:57:48] [Server thread/WARN]: at com.massivecraft.massivecore.Integration.setIntegrationActive(Integration.java:67)
[21:57:48] [Server thread/WARN]: at com.massivecraft.massivecore.Integration.setIntegrationActive(Integration.java:84)
[21:57:48] [Server thread/WARN]: at com.massivecraft.massivecore.Integration.run(Integration.java:158)
[21:57:48] [Server thread/WARN]: at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftTask.run(CraftTask.java:71)
[21:57:48] [Server thread/WARN]: at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:350)
[21:57:48] [Server thread/WARN]: at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:722)
[21:57:48] [Server thread/WARN]: at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:374)
[21:57:48] [Server thread/WARN]: at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:653)
[21:57:48] [Server thread/WARN]: at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:556)
[21:57:48] [Server thread/WARN]: at java.lang.Thread.run(Thread.java:748)
[21:57:49] [Server thread/INFO]: [Factions 2.13.7] Integration Activation IntegrationWorldGuard FAILED:
[21:57:49] [Server thread/WARN]: java.lang.Error: Unresolved compilation problem:
 

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 482
56
351
247
19
Mìlhüsa
Factions tente d'intégrer WorldGuard mais n'y arrive pas. Peut-tu nous envoyer ce qu'il y a après la ligne Unresolved compilation problem ? Je pense qu'il devrait y avoir un ClassNoFoundException.

Pense à renvoyer les logs dans des balises code :
Code:
[_code]
blablabla
[_/code]

(sans les _)

Et je pense que les deux plugins ne sont pas compatibles, sont-ils dans la bonne version ?

Cordialement,
ShE3py.
 

ddzouille0202

Cueilleur de roses
6 Janvier 2017
23
0
14
24
Bonjour merci de ta réponse !
Si je me souviens bien il n'y avait rien après mais je vais aller vérifier. Et j'ai pensé au version mais impossible de savoir quelle version de world guard il faut.

PS : Je m'excuses pour les fautes !

Édit : J'utilise le plugin Faction 2.13.7 modifier et WorldGuard 6.1
 
Dernière édition:

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 482
56
351
247
19
Mìlhüsa
Et pour les logs ?

Sinon pour les plugins prend les derniers en release pour la version du serveur.
 

ddzouille0202

Cueilleur de roses
6 Janvier 2017
23
0
14
24
Merci de ton aide !
Rien d'autre dans les logs et j'utilse la dernière version de WorldGuard pour la 1.8.8, mais pour se qui est de Factions ... Je ne sais pas et je ne peux pas le changé
 

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 482
56
351
247
19
Mìlhüsa
Envoie toutes les logs car il manque le début et la fin du stack trace.
 

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 482
56
351
247
19
Mìlhüsa
Comment t'as fait pour avoir factions version 2.13.7 sachant que sur Bukkit la dernière version étant 2.13.6 ?

Et sinon factions est en 1.12 tandis que ton WorldGuard est en 1.8. Prend WorldGuard 6.2.
 

ddzouille0202

Cueilleur de roses
6 Janvier 2017
23
0
14
24
J'ai la version développeur pour modifier les source. Et, j'ai essayer WorldGuard 6.2 mais aucun changement. :/