Résolu Probleme de connexion à mon serveur.

SundayMC_

Nouveau
29 Janvier 2021
4
0
1
17
Bonjour/Bonsoir

Tout d'abord, j'ai visionnez de nombreux forums et cela ne fonctionnait pas.

Voici mon problème :

J'héberge un serveur local (sur mon pc) et j'ai un routeur Netgear R7800 connecté à une Livebox de chez Orange (la version 4 je crois). J'ai ouvert les ports sur le portail Netgear (je n'ai pas accès au portail Orange) :
1611949080956.png

Dans le fichier server.properties j'ai indiqué : server-ip=10.0.0.5

Je démarre le serveur, chez moi j'arrive à me connecter en faisant 10.0.0.5:20000 mais mon ami (qui n'est pas chez moi et est sans hatachi) en rentrant l'adresse ip : ....***:20000, n'arrive pas à se connecter.

Informations complémentaires :

  • Mon ami et moi avons Minecraft premium
  • Le serveur est en 1.16.4 avec spigot

A mon avis, il faudrait ouvrir le port sur Netgear et Orange (mais je ne suis pas sûr).

Merci d'avance.

SundayMC
 

robin4002

Expert en informatique et systèmes d'information
Staff
Responsable technique
Responsable forum
12 Novembre 2012
18 349
65
2 854
347
23
Alsace
www.minecraftforgefrance.fr
Bonsoir,

Effectivement ton ordinateur se trouve derrière un double NAT (un premier sur la box Orange, puis un second sur le routeur Netgear), il faut donc faire le paramètre sur les deux routeurs.
 

robin4002

Expert en informatique et systèmes d'information
Staff
Responsable technique
Responsable forum
12 Novembre 2012
18 349
65
2 854
347
23
Alsace
www.minecraftforgefrance.fr
La règle minedell (25565) n'est pas utile comme tu utilise le port 20000 et la règle minehp n'avait que besoin d'être en TCP (minecraft n'utilise pas l'UDP).
Mais ça devrait être bon comme cela, allume ton serveur et essaie à nouveau.

Pour vérifier que ton serveur est accessible depuis l'extérieur, tu peux utiliser ce site : https://mcsrvstat.us/