Probleme kit essentials

Gabyhhh

Créateur de HardGlory
1 Mai 2015
28
1
6
34
Bonjour depuis environ 1mois je travaille sur mon serveur qui est finit (cauldron, bukkit)
et il me reste juste les kits mais je n'y arrive pas. Des que je mais les kits et que je fais ./essentials reload et que je fais ./kit pour voir si tous mes kits sont mis et je retrouve les kits de départ !! J'aurais bien besoin d'aide je vous mais le fichier de mon essentials/config.

http://pastebin.com/cvTPqKeJ
 

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
10 537
24
2 247
347
28
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

Alors
Code:
[12:08:49] [Server thread/ERROR]: Cannot load plugins\CombatLog\messages.properties
org.bukkit.configuration.InvalidConfigurationException: while parsing a block mapping
 in "<string>", line 15, column 1:
    Version: 1.7.11
    ^
expected <block end>, but found Scalar
 in "<string>", line 42, column 41:
     ... sage: '&8[&4CombatLog&8]&7 Tu n'es plus en combat. Tu peux te de ...
En gros ça veux dire que tu asune erreur ligne 15 et ligne 42 mais dans le plugin CombatLog (le fichier "messages.properties")

Et concernant essentials:
Code:
The file C:\Users\Pc-Gabriel\Desktop\Mon Serveur 1.7.10\plugins\Essentials\config.yml is broken, it has been renamed to C:\Users\Pc-Gabriel\Desktop\Mon Serveur 1.7.10\plugins\Essentials\config.yml.broken.1432379058633
org.yaml.snakeyaml.scanner.ScannerException: while scanning for the next token; found character         '\t' that cannot start any token
C'est une erreur de tabulation (\t)... Les tabulations ne sont pas autorisé dans les fichiers yml.
Si tu es avec un logiciel tel que Notpad++ tape ctrl+h. Sur la première ligne tu met \t et sur la seconde tu met 4 espaces. Normalement ça devrait tout te remplacer (enfin il me semble).
Sinon tu dois t'amuser à tout parcourir pour être sur qu'il n'y a pas une tabulation qui c'est glissée. Il me semble que les lignes avec une tabulation sont en rouge.

Pour éviter d'avoir le problème à l'avenir, n'oublies pas de configurer NotPad++ ;)


Cordialement,
Detobel36
 

Gabyhhh

Créateur de HardGlory
1 Mai 2015
28
1
6
34
Salut,

Alors
Code:
[12:08:49] [Server thread/ERROR]: Cannot load plugins\CombatLog\messages.properties
org.bukkit.configuration.InvalidConfigurationException: while parsing a block mapping
in "<string>", line 15, column 1:
    Version: 1.7.11
    ^
expected <block end>, but found Scalar
in "<string>", line 42, column 41:
    ... sage: '&8[&4CombatLog&8]&7 Tu n'es plus en combat. Tu peux te de ...
En gros ça veux dire que tu asune erreur ligne 15 et ligne 42 mais dans le plugin CombatLog (le fichier "messages.properties")

Et concernant essentials:
Code:
The file C:\Users\Pc-Gabriel\Desktop\Mon Serveur 1.7.10\plugins\Essentials\config.yml is broken, it has been renamed to C:\Users\Pc-Gabriel\Desktop\Mon Serveur 1.7.10\plugins\Essentials\config.yml.broken.1432379058633
org.yaml.snakeyaml.scanner.ScannerException: while scanning for the next token; found character        '\t' that cannot start any token
C'est une erreur de tabulation (\t)... Les tabulations ne sont pas autorisé dans les fichiers yml.
Si tu es avec un logiciel tel que Notpad++ tape ctrl+h. Sur la première ligne tu met \t et sur la seconde tu met 4 espaces. Normalement ça devrait tout te remplacer (enfin il me semble).
Sinon tu dois t'amuser à tout parcourir pour être sur qu'il n'y a pas une tabulation qui c'est glissée. Il me semble que les lignes avec une tabulation sont en rouge.

Pour éviter d'avoir le problème à l'avenir, n'oublies pas de configurer NotPad++ ;)


Cordialement,
Detobel36

ok merci je vais essayer
 

Gabyhhh

Créateur de HardGlory
1 Mai 2015
28
1
6
34
Salut,

Alors
Code:
[12:08:49] [Server thread/ERROR]: Cannot load plugins\CombatLog\messages.properties
org.bukkit.configuration.InvalidConfigurationException: while parsing a block mapping
in "<string>", line 15, column 1:
    Version: 1.7.11
    ^
expected <block end>, but found Scalar
in "<string>", line 42, column 41:
    ... sage: '&8[&4CombatLog&8]&7 Tu n'es plus en combat. Tu peux te de ...
En gros ça veux dire que tu asune erreur ligne 15 et ligne 42 mais dans le plugin CombatLog (le fichier "messages.properties")

Et concernant essentials:
Code:
The file C:\Users\Pc-Gabriel\Desktop\Mon Serveur 1.7.10\plugins\Essentials\config.yml is broken, it has been renamed to C:\Users\Pc-Gabriel\Desktop\Mon Serveur 1.7.10\plugins\Essentials\config.yml.broken.1432379058633
org.yaml.snakeyaml.scanner.ScannerException: while scanning for the next token; found character        '\t' that cannot start any token
C'est une erreur de tabulation (\t)... Les tabulations ne sont pas autorisé dans les fichiers yml.
Si tu es avec un logiciel tel que Notpad++ tape ctrl+h. Sur la première ligne tu met \t et sur la seconde tu met 4 espaces. Normalement ça devrait tout te remplacer (enfin il me semble).
Sinon tu dois t'amuser à tout parcourir pour être sur qu'il n'y a pas une tabulation qui c'est glissée. Il me semble que les lignes avec une tabulation sont en rouge.

Pour éviter d'avoir le problème à l'avenir, n'oublies pas de configurer NotPad++ ;)


Cordialement,
Detobel36
Cela ne marche pas j'ai enlever combatlog pour voir et apres j'ai fais ctrl+h apres j'ai fais ce que tu as dis avec /t et les 4espaces mais cela ne fonctionne pas, j'en ai marre des kits
 

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
10 537
24
2 247
347
28
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

Evite les doubles postes... Utilise plutôt le bouton "Editer" ;)
Le problème viens juste d'un tab. A toi de le trouver et de le remplacer par 4 espaces. La seul chose que je peux faire, c'est le faire à ta place.

Je viens de regarder dans le pastebin si il y avait des tabulations ou pas. Et je n'ai rien trouvé. Donc essaye de supprimer ta configuration et de copier/collé celle donner dans ton premier poste (ici: http://pastebin.com/cvTPqKeJ)


Cordialement,
Detobel36
 

Gabyhhh

Créateur de HardGlory
1 Mai 2015
28
1
6
34
Salut,

Evite les doubles postes... Utilise plutôt le bouton "Editer" ;)
Le problème viens juste d'un tab. A toi de le trouver et de le remplacer par 4 espaces. La seul chose que je peux faire, c'est le faire à ta place.

Je viens de regarder dans le pastebin si il y avait des tabulations ou pas. Et je n'ai rien trouvé. Donc essaye de supprimer ta configuration et de copier/collé celle donner dans ton premier poste (ici: http://pastebin.com/cvTPqKeJ)


Cordialement,
Detobel36

Ok et dsl pour le double post

EDIT 1: Je sais d'ou viens le probleme c'est que dans mes kits j'ai mis des armures qui sont dans des mods (comme rubis, sapphire) et il ne les reconnait pas donc je dois faire des kits normal.
Sinon je me demandais comment mettre un livre protection et sharpness dans un kit ??
 
  • J'aime
Reactions: Detobel36