probleme quand je veux crée un serveur modé

LBNcrack

Nouveau
15 Avril 2022
5
0
1
21
bonjour depuis un petit moment maintenant j'essaie de crée un serveur minecraft modé pour moi et mes potes sur le modpack FTB Révelation au par avant j'avais déja crée des servers modé sur plein de modpack mais depuis un petit moment ça me mets ce message d'erreur
sur mon pc j'ai la versions jdk-18 et la derniere versions de java 8 merci d'avance.
 

Fichiers joints

  • image_2022-04-15_110137945.png
    image_2022-04-15_110137945.png
    10 KB · Affichages: 29

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 507
57
353
247
20
Mìlhüsa
Bonjour,

Quel est ton script de lancement (le fichier .bat) ?

Cordialement,
ShE3py
 

LBNcrack

Nouveau
15 Avril 2022
5
0
1
21

Fichiers joints

  • Capture d’écran 2022-04-15 132520.png
    Capture d’écran 2022-04-15 132520.png
    29.8 KB · Affichages: 26
  • Capture.PNG
    Capture.PNG
    30.9 KB · Affichages: 25

LBNcrack

Nouveau
15 Avril 2022
5
0
1
21
mtn ça me met ça

mon msg avec la piece joint veux pas s'envoyer dcp je vais d'envoyer le texte a l'écrit


Code:
We appear to be missing one or more essential library files.
You will need to add them to your server before FML and Forge will run successfully.java.lang.ClassNotFoundException: org.objectweb.asm.Type
        at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:641)
        at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:188)
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
        at java.base/java.lang.Class.forName0(Native Method)
        at java.base/java.lang.Class.forName(Class.java:488)
        at java.base/java.lang.Class.forName(Class.java:467)
        at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:53)
        at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:34)
 

Fichiers joints

  • Capture d’écran 2022-04-15 154443.png
    Capture d’écran 2022-04-15 154443.png
    27.9 KB · Affichages: 19
Dernière édition par un modérateur:

robin4002

Expert en informatique et systèmes d'information
Staff
Responsable technique
Responsable forum
12 Novembre 2012
19 438
97
2 917
347
25
Alsace
www.minecraftforgefrance.fr
Bonsoir,

Les messages s'étaient bien envoyés, mais ils ont été mis en liste d'approbation manuelle. Je les ai acceptés et remis au propre.
 

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 507
57
353
247
20
Mìlhüsa
(En réponse à MP)

Tu as deux version de Java installées mais la commande java sélectionne la version de Java 18, met le nom complet de l'exécutable dans le script de lancement :
Code:
"C:\Program Files\Java\jre1.8.0_321\bin\java.exe" -javaagent:[etc.]
 

LBNcrack

Nouveau
15 Avril 2022
5
0
1
21
Bonsoir,

Les messages s'étaient bien envoyés, mais ils ont été mis en liste d'approbation manuelle. Je les ai acceptés et remis au propre.



(En réponse à MP)

Tu as deux version de Java installées mais la commande java sélectionne la version de Java 18, met le nom complet de l'exécutable dans le script de lancement :
Code:
"C:\Program Files\Java\jre1.8.0_321\bin\java.exe" -javaagent:[etc.]
[/QUOTE]
sorry mais je change ça ou ???
 

ShE3py

Développeur en autodidacte
Support
26 Septembre 2015
2 507
57
353
247
20
Mìlhüsa
1650053822334.png

Tu remplaces « java.exe » par « "C:\Program Files\Java\jre1.8.0_321\bin\java.exe" », en gardant les guillemets anglais et l'espace avant le « -javaagent ».