Configuration Mod Plugin Quelle version choisir ?!

Quelle version utiliser

  • Sponge Forge

    Votes: 2 66.7%
  • AtomMc

    Votes: 1 33.3%
  • Mohist

    Votes: 0 0.0%

  • Total voters
    3

Fire_Link

Bucheron
29 Octobre 2018
9
0
12
France
www.lumeria-pvp.fr
Bonjour/Bonsoir à tous.
Je suis le Fondateur d'un modeste serveur PvP Factions moddé entre autres.

Je suis confronté à un problème pour la partie moddée du serveur, je vous explique:
On m'a dit que SpongeForge est Instable, Mange la ram, et fait crash toutes les 2 minutes.
On m'a donc donné des solutions alternatives :
- Mohist (un peu comme thermos mais en 1.12.2)
- AtomMc (comme cauldron en 1.12.2)
J'ai pu tester les 3 solutions et j'en ai tiré la conculusion suivante:
-SpongeForge: Grand nombre de plugins, ca gère niveau dev, à part les performances
- AtomMc et Mohist : On peut utiliser tous les plugins de Spigot mais on ne sait pas si ces ressources seront maintenues en ligne et à jour et surtout pour combien de temps. Niveau performances, rien à redire.

J'ai environ 30 plugins et 10 mods à mettre sur le serveur, mais j'ai besoin de choisir la version avant.
On m'a dit de passer en 1.7.10, mais c'est impossible car mes autres serveurs vanilla sont reliés par bungee 1.12.2 et sont eux mêmes en 1.12.2

Je ne sais plus que dire, je m'en remets donc à vous...
Merci à ceux qui m'apporteront leur aide, je laisse le sondage en guise de décision finale ^^

Sur ce, Bonne soirée à vous !
 

DiscowZombie

Développeur
Staff
Modérateur
Support
2 Mars 2017
2 661
1
930
298
Alsace
www.discowzombie.fr
Salut,

pour moi la question ne se pose pas, Sponge. C'est le seul serveur qui a été pensé pour fonctionner réellement et durablement avec des Mods (puis des plugins), alors que les autres ont été développé pour avoir des plugins simplement mais qu'ils ont dû scotché de partout pour essayer d'intégrer les Mods ensuite. Niveau développement, l'équipe Sponge est très active, ce qui n'est pas franchement le cas des autres types de serveurs.

Pour les performances, je n'ai jamais eu plus de problèmes avec Sponge qu'avec autre chose. Cependant, lorsque tu souhaites faire tourner des Mods sur un serveur, il est primordial d'avoir une importante fréquence de processeur (c'est bien plus le processeur qui est important que la Ram). Oublie donc les offres à 2€ ou les VPS à 2 Ghz si tu souhaites avoir de bonnes performances.