Configuration Résolu Serveur Crash sans raison

BySplash

Développeur Java
2 Juillet 2019
16
0
12
25
Bonjour, comme il est dit dans le titre, mon serveur crash sans raison à partir de 2 minutes une fois démarré. Ca n'arrive que dans les version 1.8.1 à 1.11.2. Je créé un serveur faction or certains plugins ne fonctionnent pas... C'est très problèmatique... Je suis sur Debian 10

Voici l'erreur :

[05:33:29] [Netty Epoll Server IO #2/WARN]: An exceptionCaught() event was fired, and it reached at the tail of the pipeline. It usually means the last handler in the pipeline did not handle the exception.
java.lang.RuntimeException: Unable to access address of buffer
at io.netty.channel.epoll.Native.read(Native Method) ~[spigot.jar:git-Spigot-870264a-0a645a2]
at io.netty.channel.epoll.EpollSocketChannel$EpollSocketUnsafe.doReadBytes(EpollSocketChannel.java:678) [spigot.jar:git-Spigot-870264a-0a645a2]
at io.netty.channel.epoll.EpollSocketChannel$EpollSocketUnsafe.epollInReady(EpollSocketChannel.java:714) [spigot.jar:git-Spigot-870264a-0a645a2]
at io.netty.channel.epoll.EpollSocketChannel$EpollSocketUnsafe$3.run(EpollSocketChannel.java:755) [spigot.jar:git-Spigot-870264a-0a645a2]
at io.netty.util.concurrent.SingleThreadEventExecutor.runAllTasks(SingleThreadEventExecutor.java:380) [spigot.jar:git-Spigot-870264a-0a645a2]
at io.netty.channel.epoll.EpollEventLoop.run(EpollEventLoop.java:268) [spigot.jar:git-Spigot-870264a-0a645a2]
at io.netty.util.concurrent.SingleThreadEventExecutor$2.run(SingleThreadEventExecutor.java:116) [spigot.jar:git-Spigot-870264a-0a645a2]
at java.base/java.lang.Thread.run(Thread.java:834) [?:?]
 

ShE3py

Développeur en autodidacte
26 Septembre 2015
1 653
261
217
18
Mìlhüsa
Bonjour,

Minecraft ne fonctionne qu'avec Java 8, tu peux vérifier la version avec java -version.
Sinon, il faut que tu le réinstalles.

Cordialement,
ShE3py.
 

BySplash

Développeur Java
2 Juillet 2019
16
0
12
25
[email protected]:~# java -version
openjdk version "11.0.7" 2020-04-14
OpenJDK Runtime Environment (build 11.0.7+10-post-Debian-3deb10u1)
OpenJDK 64-Bit Server VM (build 11.0.7+10-post-Debian-3deb10u1, mixed mode, sharing)


c'est bon ?
 

ShE3py

Développeur en autodidacte
26 Septembre 2015
1 653
261
217
18
Mìlhüsa
Tu as Java 11 actuellement, il faut que tu passes en Java 8 donc que tu installes le JDK 8.
Bash:
sudo apt install openjdk-8-jdk
 

BySplash

Développeur Java
2 Juillet 2019
16
0
12
25
[email protected]:~# sudo apt install openjdk-8-jdk
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package openjdk-8-jdk


ça marche pas :/
 

BySplash

Développeur Java
2 Juillet 2019
16
0
12
25
j'ai réussi à passer sur java 8 ! je vais faire les tests pour voir si mon problème est réglé