Spigot server crash

RetroManiiia

Aventurier
11 Mars 2022
1
0
0
26
Salut, il y a quelques semaines, j'ai eu un problème de RAM compromise qui a été résolu, mais la semaine dernière, j'ai eu des erreurs de bloc occasionnelles qui n'étaient pas sauvegardées.


Et depuis quelques jours, c'est de pire en pire. Le souci est que depuis hier avec chaque tentative de connexion d'un jour sur le serveur, le pourcentage d'utilisation du CPU sur le ptérodactyle tombe à un maximum de 2%, et le serveur plante.


Malheureusement je ne trouve pas d'où vient le problème dans mes logs... J'espère ne pas avoir de carte corrompue, mes autres serveurs sur le même nœud pas de problème.


Serveur de log Minecraft : https://pastebin.com/ArJwkJpL

Log java : https://pastebin.com/bDZ0pZUS


Merci beaucoup


==================================================================================================================


Hi, a few weeks ago I had a compromised RAM issue which was resolved, but for the past week I've had occasional block errors that weren't saving.

And for the past few days, it's been getting worse and worse. The concern is that since yesterday with every one day connection attempt on the server, the percentage of CPU usage on pterodactyl drops to a maximum of 2%, and the server crashes.

Unfortunately I can't find where the problem comes from in my logs... I hope not to have a corrupt card, my other servers on the same node no problem.

Log server Minecraft : https://pastebin.com/ArJwkJpL
Log java : https://pastebin.com/bDZ0pZUS

thanks a lot
 

ShE3py

Enbogueuse
Support
26 Septembre 2015
3 985
153
447
247
21
Mìlhüsa
Bonsoir,

Tu as un interblocage lorsque le serveur tente de charger la map à ta connexion, concrètement deux processus qui attendent que l'autre ait fini pour continuer, sauf que vu qu'aucun des deux ne travaille le programme attendra indéfiniment, d'où ton processeur qui chute à 2% d'utilisation puisqu'il ne fait rien.

Essaye de mettre à jour ton serveur de la 1.18.1 vers la 1.18.2.

Par contre je n'ai absolument pas compris ton histoire de RAM « compromise ».

Cordialement,
ShE3py