Configuration Plugin Résolu Worldguard | Une arène PvP sur un serveur avec le PvP désactivé

Box2811HD

Massacreur de zombies
19 Juillet 2014
32
2
68
19
Bonjour à tous :D !

Je vais tout de suite vous expliquer le titre et mon problème...
J'ai un serveur survie, ou le PvP est désactivé dans le server.properties car je ne veux pas que les joueurs puissent se battre sur le serveur (survie et PvE avant tout).
Mais malgré tout, j'ai fais une arène PvP, défini avec worldguard, j'ai mis le flag "pvp" sur "allow", mais le pvp reste tout de même désactivé dans l'arène.

J'aimerai donc savoir s'il est possible d'autoriser le PvP dans une zone et de le désactivé de partout (en dehors de l'arène).
Merci d'avance pour vos réponses :) !

Cordialement,
Box2811HD.
 

Fichiers joints

Box2811HD

Massacreur de zombies
19 Juillet 2014
32
2
68
19
Bonjour,

Toujours personne pour mon problème ?
Je n'ai toujours pas trouvé de solution...

Cordialement.

EDIT :
Après encore quelques recherche j'ai pu enfin trouvé une solution.
Pour ceux qui lirait ce topic, si vous utilisez worldguard.
Mettez pvp=true dans votre server.properties, et taper la commande en jeu
/rg flag global pvp deny
qui aura pour effet de désactivé le pvp sur l'entièreté du serveur. Et ensuite vous faite la même commande avec cette fois votre région pvp et en mettant allow au flag pvp ("/rg flag <nom_de_la_region> pvp allow").
Voilà.
 
Dernière édition:

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
9 650
2 122
347
24
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

/rg flag global pvp deny
Normalement c'est la commande:
/rg flag __global__ pvp deny

Et pour expliqué pourquoi il faut faire ça et non pas ce qui est expliqué dans le premier poste:
les propriétés du serveurs sont prioritaires sur les plugins. Donc si vous bloqué le PvP... Et bien le PvP est bloqué partout :)
Il faut donc tout gérer via WorldGuard.


Cordialement,
Detobel36
 

Box2811HD

Massacreur de zombies
19 Juillet 2014
32
2
68
19
Salut !

Oui je l'ai remarqué bien après :D ! Grâce à un très vieux poste.
Mais merci beaucoup de ton aide :).