Crash après un load d'un schematics

RevolTinvoC

Ramasseur de champignons
6 Janvier 2018
16
1
0
12
21
Salut,

J'ai load un spawn que nous avons puis quand on veut le load sur notre serveur sa crash voici l'erreur sur ce pastebin : http://pastebin.fr/64580


Le serveur à exactement en ram ceci :

@echo off
java -Xms1024M -Xmx2048M -jar spigot.jar
pause


j'aimerai savoir qu'elle truc cause cette erreur c'est vraiment important.

aussi je tien a dire que le spawn fait un fichier du coup de 184ko.

merci bien.
 

Cercus

Un modérateur chat trop mignon
Staff
Modérateur
6 Octobre 2013
792
77
152
24
Une des raisons est peut être que le nombre de RAM que tu as mis sur ton serveur n'est pas suffisant pour charger ce schematic
 

ShE3py

Enbogueuse
Support
26 Septembre 2015
2 769
70
373
247
20
Mìlhüsa
Bonsoir,

Les logs que tu as envoyés n'indiquent pas un manque de mémoire, mais plutôt que le watchdog a considéré le serveur comme crashé parce que WorldEdit freezait le jeu pendant trop longtemps.
Tu peux enlever le fait que WorldEdit doivent faire ses calculs dans un temps impartit en modifiant ton server.properties :
Code:
max-tick-time=-1

La valeur correspond au nombre maximal de millisecondes qu'un tick du serveur peut prendre, sachant qu'un tick doit prendre moins de 0.05 secondes pour que le serveur ne lag pas. La valeur par défaut est 60000 (une minute), tu peux aussi l'augmenter à par exemple cinq minutes.

Et sinon, tu n'as envoyé qu'une partie des logs (probablement celles que tu voyais), à l'avenir envoie tout le contenu du fichier logs/lasted.log.

Cordialement,
ShE3py.
 

RevolTinvoC

Ramasseur de champignons
6 Janvier 2018
16
1
0
12
21
Bonsoir,

Les logs que tu as envoyés n'indiquent pas un manque de mémoire, mais plutôt que le watchdog a considéré le serveur comme crashé parce que WorldEdit freezait le jeu pendant trop longtemps.
Tu peux enlever le fait que WorldEdit doivent faire ses calculs dans un temps impartit en modifiant ton server.properties :
Code:
max-tick-time=-1

La valeur correspond au nombre maximal de millisecondes qu'un tick du serveur peut prendre, sachant qu'un tick doit prendre moins de 0.05 secondes pour que le serveur ne lag pas. La valeur par défaut est 60000 (une minute), tu peux aussi l'augmenter à par exemple cinq minutes.

Et sinon, tu n'as envoyé qu'une partie des logs (probablement celles que tu voyais), à l'avenir envoie tout le contenu du fichier logs/lasted.log.

Cordialement,
ShE3py.
j'ai pas de max tick time dans mons server.properties

Cordialement
 

ShE3py

Enbogueuse
Support
26 Septembre 2015
2 769
70
373
247
20
Mìlhüsa
Étrange, j'ai dû me tromper avec l'historique du wiki, je croyais que la propriété était disponible en 1.9.

Tu dois passer par le fichier spigot.yml :
YAML:
settings:
  [...]
  timeout-time: 60


Le temps est cette fois-ci exprimé en secondes, je ne sais pas si mettre -1 ou 0 le désactiverai, donc dans le doute met-le sur 5 minutes (300 secondes) ou plus.