Virtu-all_Gamer

Massacreur de Mouton
28 Août 2017
31
1
2
19
24
Bonjour, j'ai créer un pack de texture avec de la white concrete lumineuse, puis j'ai voulu rendre la vitre normal plus belle en enlevant les imperfections sur les côtés et aussi les bords. Mais cela n'as jamais marcher.
Voici la texture dans paint.net :

upload_2019-8-31_16-15-21.png


Donc, j'ai simplement pris une image de 16x16 puis supprimer le tout pour que cela soit transparent et appliquer une texture blanche transparente. (ça fait un filtre plutôt sympa).

upload_2019-8-31_16-18-53.png


Et c'est ici que cela devient compliquer car : j'ai le choix de mettre le mode "détecter automatiquement" ou de choisir les paramètres tout seul. Quand je laisse en "détecter automatiquement" cela donne ça sur mon bureau :

upload_2019-8-31_16-22-57.png


Très bien, donc je le met dans mon Texture Pack 1.14 sous le nom de : "glass" :

upload_2019-8-31_16-26-40.png


Et dans le jeu, cela donne ça :
Dans l'inventaire :
upload_2019-8-31_16-29-15.png


Et poser à terre ou contre un mur :
2019-08-31_16.30.17.png


La vitre est entièrement transparente.
Vous allez donc me dire de mettre la texture blanche moins transparente !
Mais... celle-ci dans paint.net :

upload_2019-8-31_16-34-38.png


Devient ceci... dans Minecraft :
Dans l'inventaire :
upload_2019-8-31_16-37-6.png


Et puis contre un mur et au sol :
2019-08-31_16.38.45.png
2019-08-31_16.38.57.png


Je ne sais plus quoi faire. Je met évidemment toute mes images en PNG.
J'ai essayer différents niveaux de tramage tout comme plusieurs seuil de transparence dans les réglages de paint.net !
upload_2019-8-31_16-18-53.png
J'ai essayer de prendre la texture des anciennes vitre de Minecraft, ce la n'as pas marché et en plus...
J'ai tenter de mettre tout simplement la texture de l'ancienne vitre en 1.14 et ça a fait n'importe quoi. Même cette texture n'était pas transparente ! Soit elle l'est totalement, ou soit elle ne l'est pas du tout !
Si quelqu'un comprend ce problème, je le remercie de me partager ça Svp !
Merci !
 

Theinformateur333

Aventurier
17 Août 2019
35
4
9
27
Bonjour, j'ai créer un pack de texture avec de la white concrete lumineuse, puis j'ai voulu rendre la vitre normal plus belle en enlevant les imperfections sur les côtés et aussi les bords. Mais cela n'as jamais marcher.
Voici la texture dans paint.net :

Voir la pièce jointe 84369

Donc, j'ai simplement pris une image de 16x16 puis supprimer le tout pour que cela soit transparent et appliquer une texture blanche transparente. (ça fait un filtre plutôt sympa).

Voir la pièce jointe 84370

Et c'est ici que cela devient compliquer car : j'ai le choix de mettre le mode "détecter automatiquement" ou de choisir les paramètres tout seul. Quand je laisse en "détecter automatiquement" cela donne ça sur mon bureau :

Voir la pièce jointe 84371

Très bien, donc je le met dans mon Texture Pack 1.14 sous le nom de : "glass" :

Voir la pièce jointe 84372

Et dans le jeu, cela donne ça :
Dans l'inventaire :
Voir la pièce jointe 84373

Et poser à terre ou contre un mur :
Voir la pièce jointe 84374

La vitre est entièrement transparente.
Vous allez donc me dire de mettre la texture blanche moins transparente !
Mais... celle-ci dans paint.net :

Voir la pièce jointe 84375

Devient ceci... dans Minecraft :
Dans l'inventaire :
Voir la pièce jointe 84376

Et puis contre un mur et au sol :
Voir la pièce jointe 84377 Voir la pièce jointe 84378

Je ne sais plus quoi faire. Je met évidemment toute mes images en PNG.
J'ai essayer différents niveaux de tramage tout comme plusieurs seuil de transparence dans les réglages de paint.net !
Voir la pièce jointe 84370
J'ai essayer de prendre la texture des anciennes vitre de Minecraft, ce la n'as pas marché et en plus...
J'ai tenter de mettre tout simplement la texture de l'ancienne vitre en 1.14 et ça a fait n'importe quoi. Même cette texture n'était pas transparente ! Soit elle l'est totalement, ou soit elle ne l'est pas du tout !
Si quelqu'un comprend ce problème, je le remercie de me partager ça Svp !
Merci !
Je suis pas un expert mais je dirais que ses un beuger entre ta version et ton pack que tu a créé ,est tu en 1.14/1.14.1... Si tu est à la version 1.14.2 par exemple prendre la version supérieur et si tu est à la dernière ba soit tu attends une mise à jour soit tu régresse ta version juste qu'à avoir une version ou tu n'a pas le bug.

De toute façon tu a une incompatibilité entre les fichiers donc soit tu suis mon conseil soit tu essayes de modifier ton pack avec un bon programmeur (si tu choisi cette option bonne chance)
 
Dernière édition:

Virtu-all_Gamer

Massacreur de Mouton
28 Août 2017
31
1
2
19
24
Je suis pas un expert mais je dirais que ses un beuger entre ta version et ton pack que tu a créé ,est tu en 1.14/1.14.1... Si tu est à la version 1.14.2 par exemple prendre la version supérieur et si tu est à la dernière ba soit tu attends une mise à jour soit tu régresse ta version juste qu'à avoir une version ou tu n'a pas le bug.

De toute façon tu a une incompatibilité entre les fichiers donc soit tu suis mon conseil soit tu essayes de modifier ton pack avec un bon programmeur (si tu choisi cette option bonne chance)

Merci à toi, c'est très intéressant ce que tu dit ! J'ai quelques idées de quoi faire maintenant ! Merci!
 

robin4002

Expert en informatique et systèmes d'information
Staff
Responsable technique
Responsable forum
12 Novembre 2012
20 855
157
3 002
347
26
Alsace
www.minecraftforgefrance.fr
Bonsoir,
Avec la transparence partielle ça semble bon en main mais pas sur le monde, donc le fichier est bon mais le problème vient du rendu du bloc dans le monde qui ne gère pas la semi-transparence.
Malheureusement tu n'y peux pas grand chose dans ce cas, ça dépend du code de Mojang ça ...