Impossible de rejoindre un serveur Minecraft Forge

SkY_InOx

Aventurier
27 Octobre 2020
12
0
1
33
Bonjours,
Je viens vers vous pour m'aider à régler un problème que j'ai lorsqu'un pote essaye de rejoindre mon serveur Minecraft Forgé 1.12.2. Alors le soucis exacte est que lorsqu'il essayé de rejoindre le serveur avec mon IP sur Hamachi ( on est dans le même réseau sur Hamachi ) , il vois bien qu'il y a quelqu'un dans le serveur ( soit moi ), il le voit en ligne avec environ 120/130 ms mais lorsqu'il essaye de ce connecter , cela écrit ce message d'erreur : "Connection time out" ou parfois "vous avez été déconnecté" !
Si quelqu'un passe par là, merci de bien m'aider à régler ce problème !
Bonne fin de journée à vous
PS : Moi j'arrive à me connecter sans problème et lorsqu'il rejoint je vois dans la console du serveur qu'il rejoint et juste après au moment de son message j'ai exactement le même mais en code bien sûr ! Encore Merci
 

robin4002

Expert en informatique et systèmes d'information
Staff
Responsable technique
Responsable forum
12 Novembre 2012
20 855
157
3 002
347
26
Alsace
www.minecraftforgefrance.fr
Ah c'est probablement car tu as mis ton ip hamachi dans server.properties, donc le serveur n'accepte que des connexions depuis hamachi.
Laisse la valeur vide, donc ne mets rien après le = après server-ip afin que le serveur écoute sur toutes les ip disponible.
 

SkY_InOx

Aventurier
27 Octobre 2020
12
0
1
33
Donc je résume , je supprime l'IP dans server-ip , pour ensuite que je me connecte avec localhost et ensuite mon pote se connecte avec l'IP qu'il y a sur Hamachi ?!
 

robin4002

Expert en informatique et systèmes d'information
Staff
Responsable technique
Responsable forum
12 Novembre 2012
20 855
157
3 002
347
26
Alsace
www.minecraftforgefrance.fr
Oui. Sauf erreur de ma part cela devrait fonctionner.
Et si tout ce déroule bien ainsi, cela laisse penser que le facteur limitant est le débit d'hamachi.

Passer par l'ouverture des ports devraient donner de meilleur performance, mais ce n'est pas possible en 4G.
 

SkY_InOx

Aventurier
27 Octobre 2020
12
0
1
33
Alors cela maintenant fonctionne lorsque je me connecte en local et mon pote arrive à ce connecté avec l'ip Hamachi mais lorsqu'il spawn, il est directement deco du serveur avec l'erreur = " connexion perdu ". Auriez-t-il un moyen d'éviter de passer par Hamachi pour ce connecté au serveur ?
 

robin4002

Expert en informatique et systèmes d'information
Staff
Responsable technique
Responsable forum
12 Novembre 2012
20 855
157
3 002
347
26
Alsace
www.minecraftforgefrance.fr
Oui, comme ça :