Plugin Plugin ProtocolLib fonctionne pas sur mon serveur Thermos 1.7.10 openmod

Discussion dans 'Support serveur et plugins' créé par Math_Cnz, 4 Janvier 2019.

  1. DiscowZombie

    DiscowZombie Dev passionné
    Staff Modérateur Support

    Inscrit:
    2 Mars 2017
    Messages:
    2 281
    J'aime reçus:
    743
    Salut,

    si tu as un problème, tu le postes ici. Pas besoin d'aller sur Discord. ;)
     
  2. Math_Cnz

    Math_Cnz Nouveau

    Inscrit:
    4 Janvier 2019
    Messages:
    9
    J'aime reçus:
    0
    Sa ne fonctionne pas
    Voici les logs

    14:22:42] [Server thread/ERROR]: Could not load 'plugins/ProtocolLib(1).jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: main class `com.comphenix.protocol.ProtocolLibrary' does not extend JavaPlugin
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:198) ~[PluginClassLoader.class:1.7.10-1614.57]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:145) ~[JavaPluginLoader.class:1.7.10-1614.57]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:334) ~[SimplePluginManager.class:1.7.10-1614.57]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:256) [SimplePluginManager.class:1.7.10-1614.57]
    at org.bukkit.craftbukkit.v1_7_R4.CraftServer.loadPlugins(CraftServer.java:343) [CraftServer.class:1.7.10-1614.57]
    at net.minecraft.world.storage.SaveHandler.initBukkitData(SaveHandler.java:462) [ayq.class:?]
    at net.minecraft.world.storage.SaveHandler.func_75757_d(SaveHandler.java:138) [ayq.class:?]
    at net.minecraft.world.World.<init>(World.java:374) [ahb.class:?]
    at net.minecraft.world.WorldServer.<init>(WorldServer.java:162) [mt.class:?]
    at net.minecraft.server.MinecraftServer.func_71247_a(MinecraftServer.java:375) [MinecraftServer.class:?]
    at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:337) [lt.class:?]
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:643) [MinecraftServer.class:?]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_72]
    Caused by: java.lang.ClassCastException: class com.comphenix.protocol.ProtocolLibrary
    at java.lang.Class.asSubclass(Class.java:3404) ~[?:1.8.0_72]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:196) ~[PluginClassLoader.class:1.7.10-1614.57]
    ... 12 more
     
  3. DiscowZombie

    DiscowZombie Dev passionné
    Staff Modérateur Support

    Inscrit:
    2 Mars 2017
    Messages:
    2 281
    J'aime reçus:
    743
    Salut,

    cette erreur n'a pas lui d'être, la classe extends bien JavaPlugin. Tu as bien pris la bonne version et tu n'as pas de plugins qui pourraient poser de problèmes avec ? (si tu utilises déjà des plugins qui ont besoin de ProtocolLibs, enlève-les et essaie juste avec ProtocolsLibs).
     
  4. Math_Cnz

    Math_Cnz Nouveau

    Inscrit:
    4 Janvier 2019
    Messages:
    9
    J'aime reçus:
    0
    Il y a quoi comme plugins qui pourrai poser problème ? Jsonapi ?

    AKTator.jar
    Désactiver
    AdvancedAchievements.jar
    Désactiver
    AdvancedItemEffects(1).jar
    Désactiver
    Announcer.jar
    Désactiver
    AntiProxy.jar
    Désactiver
    AntiWDL(1).jar
    Désactiver
    Antidupli-AKT.jar
    Désactiver
    AppleCoodown.jar
    Désactiver
    ArcaneEnchants(1).jar
    Désactiver
    AsyncWorldEditInjector.jar
    Désactiver
    AuctionHouse5.jar
    Désactiver
    AuthMe.jar
    Désactiver
    BANACCAKT.jar
    Désactiver
    BanItem.jar
    Désactiver
    Bottlexp_fixed.jar
    Désactiver
    CHATJEUAKT.jar
    Désactiver
    ColoredSigns.jar
    Désactiver
    CombatApples.jar
    Désactiver
    CombatTagPlus.jar
    Désactiver
    CraftsPlus.jar
    Désactiver
    CreateYourOwnMenus-0.5.9.jar
    Désactiver
    CustomEnderChest-v1.8.0.jar
    Désactiver
    EnchantTableLevel.jar
    Désactiver
    EnderPearlCooldown-1.5.0.jar
    Désactiver
    Essentials.jar
    Désactiver
    EssentialsChat.jar
    Désactiver
    EssentialsGeoIP.jar
    Désactiver
    EssentialsGroupManager.jar
    Désactiver
    EssentialsProtect.jar
    Désactiver
    EssentialsSpawn.jar
    Désactiver
    ExtrasSK.jar
    Désactiver
    FactionsUUID-1.6.9.5.jar
    Désactiver
    Forcefield.jar
    Désactiver
    GUNAKT.jar
    Désactiver
    GoreaRestrict_V3.1.jar
    Désactiver
    HolographicDisplays.jar
    Désactiver
    HolographicDisplaysPatch.jar
    Désactiver
    KeepChunks.jar
    Désactiver
    KitAdder.jar
    Désactiver
    LuckyBox-AKT.jar
    Désactiver
    MOBSTACK-AKT.jar
    Désactiver
    MUSICAKT.jar
    Désactiver
    MassiveCore(4).jar
    Désactiver
    MineResetLite.jar
    Désactiver
    Multiverse-Core-2.4(2).jar
    Désactiver
    Multiverse-Portals-2.4(3).jar
    Désactiver
    MythicMobs-1.1.8.jar
    Désactiver
    ObsidianBreaker.jar
    Désactiver
    ObsidianDestroyer.jar
    Désactiver
    OtherDrops.jar
    Désactiver
    PirateSK-0.4.1.jar
    Désactiver
    PlayEffecakt.jar
    Désactiver
    ProtocolLib(1).jar
    Désactiver
    QuickShop.jar
    Désactiver
    ShopGUIPlus-1.2.9-SNAPSHOT.jar
    Désactiver
    Shopkeepers.jar
    Désactiver
    SimpleHub.jar
    Désactiver
    SkAction 2.2.jar
    Désactiver
    SkQuery(2).jar
    Désactiver
    SkinsModule.jar
    Désactiver
    Skript.jar
    Désactiver
    Spawner.jar
    Désactiver
    StaffGUI.jar
    Désactiver
    Trading_v3.2.jar
    Désactiver
    UltimateCasino5.jar
    Désactiver
    Vault.jar
    Désactiver
    WildSkript.jar
    Désactiver
    WorldBorder.jar
    Désactiver
    capple.jar
    Désactiver
    coloredtablist.jar
    Désactiver
    iConomy.jar
    Désactiver
    mineweb_bridge-2.0.0 (1).jar
    Désactiver
    skRayFall_v1.7.3.jar
    Désactiver
    worldedit-bukkit-6.1(3).jar
    Désactiver
    worldguard-6.1(1).jar
     
    #14 Math_Cnz, 10 Janvier 2019, à 17:45
    Dernière édition par un modérateur: 10 Janvier 2019, à 17:57
  5. DiscowZombie

    DiscowZombie Dev passionné
    Staff Modérateur Support

    Inscrit:
    2 Mars 2017
    Messages:
    2 281
    J'aime reçus:
    743
    Re,

    donc oui JsonAPI.

    En outre, le double-post est interdit sur le forum. Utilise le bouton "Éditer" pour modifier un message quelques instants après l'avoir envoyé.
     
  6. Math_Cnz

    Math_Cnz Nouveau

    Inscrit:
    4 Janvier 2019
    Messages:
    9
    J'aime reçus:
    0
    Re Bonjour
    Il n y avait déjà plus jsonapi
    Mais le plugin se s affiche plus dans /pl

    Comment je peut faire ?
     
  7. DiscowZombie

    DiscowZombie Dev passionné
    Staff Modérateur Support

    Inscrit:
    2 Mars 2017
    Messages:
    2 281
    J'aime reçus:
    743
    Re,

    Ceci étant dit, je n'ai pas beaucoup d'idées d'où peut venir le problème. Ces versions sont très anciennes donc bon...
     
  8. Math_Cnz

    Math_Cnz Nouveau

    Inscrit:
    4 Janvier 2019
    Messages:
    9
    J'aime reçus:
    0
    En revanche que je fasse comment ? La dernière solution car il faut que je relie mon site au serv
     

Partager cette page