Mod Problème avec crafttweaker

extazy_matt

Bucheron
11 Juin 2020
19
3
13
24
Bonjour, j'ai récemment décidé de créer un modpack, et puis j'ai vu que CraftTweaker me serais bien utile pour la suite j'ai alors commencé à faire un script ZS et problème, une erreur est détecté je ne sais pas comment la régler, j'ai bien essayer de suivre un tuto ou même de vérifier sur le wiki de CraftTweaker mais je n'ai rien trouver.
Voici mon code:
Code:
import crafttweaker.item.IItemstack;

var items = [
    <item:minecraft:stone>,
    <item:minecraft:granite>,
    <item:minecraft:diorite>,
    <item:minecraft:andesite>
] as IItemstack[];

Qui a pour seul but de lister ses 4 items.

Et voici les logs et le message d'erreur :
Code:
[13:04:40.629][DONE][SERVER][INFO] Started loading Scripts for Loader 'crafttweaker'!
[13:04:40.693][DONE][SERVER][INFO] Loading Onecraft.zs
[13:04:40.694][DONE][SERVER][ERROR] org.openzen.zencode.shared.CompileException: Could not find type crafttweaker.item.IItemstack
[13:04:40.694][DONE][SERVER][ERROR] ERROR Onecraft.zs:3:12: Could not cast IItemStack to invalid
[13:04:40.694][DONE][SERVER][ERROR] ERROR Onecraft.zs:3:12: Could not cast IItemStack to invalid
[13:04:40.694][DONE][SERVER][ERROR] ERROR Onecraft.zs:3:12: Could not cast IItemStack to invalid
[13:04:40.694][DONE][SERVER][ERROR] ERROR Onecraft.zs:3:12: Could not cast IItemStack to invalid
[13:04:40.694][DONE][SERVER][ERROR] Scripts are invalid!
[13:04:40.695][DONE][SERVER][INFO] Finished loading Scripts!
[13:05:02.370][DONE][CLIENT][INFO] Loading Onecraft.zs
[13:05:02.371][DONE][CLIENT][ERROR] org.openzen.zencode.shared.CompileException: Could not find type crafttweaker.item.IItemstack
[13:05:02.372][DONE][CLIENT][ERROR] ERROR Onecraft.zs:3:12: Could not cast IItemStack to invalid
[13:05:02.372][DONE][CLIENT][ERROR] ERROR Onecraft.zs:3:12: Could not cast IItemStack to invalid
[13:05:02.372][DONE][CLIENT][ERROR] ERROR Onecraft.zs:3:12: Could not cast IItemStack to invalid
[13:05:02.372][DONE][CLIENT][ERROR] ERROR Onecraft.zs:3:12: Could not cast IItemStack to invalid
[13:05:02.372][DONE][CLIENT][ERROR] Scripts are invalid!

Si vous savez comment régler cette erreur s'il vous plait aidez moi.
 
Dernière édition par un modérateur:

ShE3py

Enbogueuse
Support
26 Septembre 2015
4 125
161
460
247
21
Mìlhüsa
Bonjour,

La plupart des langages de programmation sont sensibles à la casse, et tu as oublié une majuscule dans le type des items : « IItemStack ».

Préfère aussi copier-coller le code sources et les logs dans des balises [code][/code] :
Code:
[code]
Copie-colle le contenu du fichier entre ces deux balises à réécrire
[*/code]

Sans l'astérisque « * » ; préfère aussi modifier ton message plutôt que d'en poster plusieurs à la suite.

Cordialement,
ShE3py