Problème modifyworld et permissions

Echec-Critique

Plug'N Play
1 Avril 2012
2 010
172
182
France
Donne ton fichier permission en le mettant entre balises CODE (c'est un des boutons dans la bande blanche au dessus de l'endroit pour écrire une réponse.
 

Shanon

Aventurier
18 Juillet 2013
8
0
1
31
Bonjour,

Je ne sais pas si je suis au bon endroit, j'ai trouvé ce post par hasard en essayant de me renseigner pour mon problème donc j'en profite pour ne pas en créer un autre.

J'ai un problème exactement identique sauf que pour ma part, j'ai aussi essayé bPermission et cela ne fonctionne pas non plus (plugin en rouge)

Alors j'explique.
J'ai fais et refais et re-refais mon dossier permission pour le plugin PermissionsEx mais rien a faire. A chaque fois qu'un joueur Citoyen essaye de casser des blocs, en poser, etc... et bien il ne peut pas.
J'ai cherché des tutos, des infos, rien y fait..
Quand nous sommes Op, ça marche, une fois Deop, ça ne va plus. Quand j'arrive a avoir les commandes de base comme /spawn, le reste ne veut pas suivre..

Ce serait sympa de m'éclairer, j'en peux vraiment plus !

Mon fichier permission actuel (juste refait) :

Code:
groups:
  Citoyen:
    default: true
    permissions:
    - modifyworld.*
    - essentials.help
    - essentials.sethome
    - essentials.sethome
    - creativesgates.use
    - essentials.home
    - essentials.afk
    - essentials.spawn
    - essentials.motd
    - essentials.who
    - essentials.rules
    - essentials.back
    - essentials.balance
    - essentials.balance.others
    - essentials.tpaccept
    - essentials.warp
    - essentials.warplist
    - essentials.tpa
    - essentials.tphere
    - essentials.kit.tools
    prefix: '§2[Citoyen]§2'
  Modérateur:
    default: false
    permissions:
    - modifyworld.*
    - essentials.help
    - essentials.sethome
    - essentials.sethome
    - creativesgates.use
    - essentials.home
    - essentials.afk
    - essentials.spawn
    - essentials.motd
    - essentials.who
    - essentials.rules
    - essentials.back
    - essentials.balance
    - essentials.balance.others
    - essentials.tpaccept
    - essentials.warp
    - essentials.warplist
    - essentials.tpa
    - essentials.tphere
    - essentials.kit.tools
    prefix: '§1[Modérateur]§1'
  Admin:
    default: false
    permissions:
    - modifyworld.*
    - '*'
    prefix: '§4[Admin]§4'

Merci d'avance.

Petite précision : Pour chaque tentative, ça me marque " You are not permitted to interact with ... "
 

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
10 539
24
2 247
347
28
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

A mon avis, tu a installé EssentialsAntiBuild... C'est complètement inutile, car EssentialsAntiBuild fait exactement la même chose que ModifyWorld...
Supprime EssentialsAntiBuild et t'aura normalement plus de problème.


Cordialement,
Detobel36
 

Shanon

Aventurier
18 Juillet 2013
8
0
1
31
Salut,

Merci pour la réponse rapide, je n'ai pas installé EssentialAntiBuild, les seuls plugins essentials que j'ai sont :
Essentials et EssentialCommands
A moins qu'ils soit déjà mis dans Essentials par avance...
Je ne comprend pas grand chose, je commence a force de regarder les tutos mais je ne trouve vraiment pas le problème..

Ma liste de plugins actuels pour plus d'info :
Essentials
EssentialCommands
AutoSaveWorld
CreativeGates
Multiworld
WorldBorder
mychatmanager
CraftBukkitUpToDate
mcore
Mob Spawner Modification Commands
SuperItem
Secure Chests
EnderRespawn
ChestShop (iConomyChestShop)
AdminShop
Simple Prefix
MyChunk
Factions
AuthMe Reloaded
WorldEdit
AntiExplosion
WorldGuard

Certains de ces plugins ne me servent pas et je vais d'ailleurs en supprimer, le serveur est tout juste en cours de création.

Edit:
Rectification, j'en ai oublié qui ne figurent pas sur ma liste et sont pourtant sur le serveur lorsque je tape /plugins :
Multiverse-Core, EssentialsProtec, EssentialsSpawn, EssentialsAntiBuild, EssentialsChat.
A moins qu'ils soient dans "Essentials", je ne vois pas comment ils sont arrivés.

Je supprime donc EssentialsAntiBuild et te tiens au courant.
 

Shanon

Aventurier
18 Juillet 2013
8
0
1
31
Après avoir delete EssentialsAntiBuild, j'ai refais a nouveau mon PermissionEx et toujours pareil...
"You are not permitted to interact with ..."

Help me please, je ne m'en sors vraiment pas ! :(

Merci d'avance.
 

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
10 539
24
2 247
347
28
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

Peux tu écrire le message complet stp. Cela me permettra de voir quel plugin est a la source du problème.
Vérifie que t'a bien redémarré ton serveur après avoir supprimé EssentialsAntiBuild.
Et pour infos, essentials se télécharge en .zip (ou .rar, je sais plus) et il faut le déziper pour n'avoir plus que les .jar. Sauf que dans cette archive, il y a plusieurs composante de essentials. Essentials, EssentialsProtect, EssentialsSpawn, .... Tu n'a peux être pas besoin de toutes les extensions de essentials. Renseigne toi, et supprime ce qui ne t'intéresse pas.


Cordialement,
Detobel36
 

Shanon

Aventurier
18 Juillet 2013
8
0
1
31
Bonjour,

Alors pour le message, ça me met un bloc, par exemple si je clique sur de la grass ça va me mettre :
"You are not permitted to interact with grass"

Ensuite, sur l'hébergeur ou je suis, il propose un service d'installation de plugins, c'est vrai que c'est plus rapide, ça évite les fails mais c'est pas toujours bien..
Du coup, je vais installer tous les plugins 1 par 1 et reprendre mes maps quand ça sera fini niveau plugins..
Je risque surement d'avoir encore besoin d'aide au niveau de PermissionEx car je ne suis pas très "calé" dessus..
Je vous tiendrais au courant.

Merci encore.
 

Shanon

Aventurier
18 Juillet 2013
8
0
1
31
Hihihi, aussi je n'avais pas vu cela : EssentialsProtect rentre en conflit avec WorldGuard*
ça pourrait etre sympa de lire parfois... (Tête de noeud)

Bon bah il est fort possible que mon problème vienne de là, je vais voir et je vous tiens au courant.

J'avais bel et bien désinstallé EssentialAntiBuild mais pas EssentialsProtect...