Problème Plugin SwornGuns

PanzerPryme

Aventurier
28 Décembre 2017
20
0
4
20
Bonjour,
Je vous remercie pour votre aide d'avance ! :D

J'ai voulu modifier un texte (lorsque qu'on recharge de "RELOADING" en "RECHARGEMENT" sur un plugin s'appelant "SwornGuns" . Mais lorsque que je le lance sur mon serveur, il marche correctement, hormis les armes... et dans la console, je peux y retrouver un code d'erreur sur quelque chose que je ne comprends absolument pas :'s

PS : J'ai joint les logs par fichier, afin de ne pas prendre trop de place .

je vous remercie encore pour votre aide !
 

Fichiers joints

  • Code Erreur Magic SwornGuns.txt
    4.2 KB · Affichages: 235

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
10 536
24
2 247
347
28
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

Heu... Tu n'est pas au bon endroit. Ici c'est pour se présenter. Tu ne te présente pas du tout, tu expliques un problème. Tu aurais du poster dans "Support serveur et plugins"... Je signale à un modérateur pour qu'il déplace ton poste.

Pour le problème à proprement parlé, as-tu pris la version sur bukkit org où as-tu téléchargé la version dev ?
Car la version sur bukkit date de 2014 alors que la version dev elle a été mise à jour il y a 5 mois. Le soucis vont donc surement de la.
Tu trouvera la version dev ici: http://ci.minesworn.com/job/SwornGuns/


Cordialement,
Detobel36
 

PanzerPryme

Aventurier
28 Décembre 2017
20
0
4
20
Bonjour,
Merci énormement de votre aide, je n'ai pas encore essayez mais ça fait toujours plaisir que quelqu'un vienne nous aider, et vu votre argument, je crois bien que c'est cela qui cloche :D
(je l'avais téléchargée sur bukkit.org)

j'ai converti le fichier "SwornGuns.jar" en ".zip" afin de l'ouvrir avec Eclipse et y apporter ma modification, mais Eclipseme signale une erreur : The class file is not on the classpath .
 
Dernière édition par un modérateur:

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
10 536
24
2 247
347
28
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

Bonjour, j'ai converti le fichier "SwornGuns.jar" en ".zip" afin de l'ouvrir avec Eclipse et y apporter ma modification, mais Eclipse n'arrive pas a ouvrir un fichier ".class" j'aurai besoin de votre aide pour savoir comment faire, car j'ai oublié comment j'ai fait avant :s
  1. Les doubles postes sont interdit sur le forum, il y a le bouton "Editer" pour ça
  2. Pas besoin de convertir en .zip pour pouvoir ouvrir un .jar avec un gestionnaire d'archive
  3. Pour pouvoir modifier un plugin il faut le décompiller et non pas le décompresser. Un plugin est écrit en java dans des fichiers lisible par l'Homme se finissant en .java. Lorsque l'on compile le plugin, il transforme ces fichiers en .class qui sont des fichiers lisible par un ordinateur (mais plus par l'Homme). Pour pouvoir faire l'opération inverse il faut un logiciel qui va décompiller. Sache que pour certains plugins/programme c'est illégal (en fonction de la licence qu'il y a sur le produit).
    As-tu seulement essayé la version dev ? Qu'as-tu comme message d'erreur si tel est le cas ?

Cordialement,
Detobel36
 
  • J'aime
Reactions: robin4002

PanzerPryme

Aventurier
28 Décembre 2017
20
0
4
20
Ah c'est bon ! j'ai réussi a l'ouvrir, et j'ai apporté ma modification, je vais maintenant l'exporter en ".jar" et l'essayer ! :D
 

robin4002

Expert en informatique et systèmes d'information
Staff
Responsable technique
Responsable forum
12 Novembre 2012
20 928
159
3 004
347
27
Alsace
www.minecraftforgefrance.fr
Bonjour,
J'ai déplacé la discussion dans la bonne section et j'ai fusionné les doubles posts.
Merci de faire plus attention à l'avenir afin de garder le forum en ordre ;)
 
  • J'aime
Reactions: PanzerPryme

PanzerPryme

Aventurier
28 Décembre 2017
20
0
4
20
ah bah non en fait... j'ai décompilé le fichier en ".zip" et l'ai ouvert avec Eclipse, problème lorsque que les fichiers sortent du décompileur, des erreurs apparaissent.
 

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
10 536
24
2 247
347
28
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

Si tu veux de l'aide vaut mieux répondre aux questions que l'on te pose... Si tu veux résoudre le problème tout seul, tant mieux pour toi mais alors ça sert à rien de poster encore des messages ici...

As-tu seulement essayé la version dev ? Qu'as-tu comme message d'erreur si tel est le cas ?


Cordialement,
Detobel36