Serveur Moddé sous Forge et Spigot en 1.8? (Autre que Sponge)

Kenda

Massacreur de zombies
16 Juillet 2016
265
1
2
125
30
www.youtube.com
Bonjour/Bonsoir,


Voilà, cela va faire 3-4 mois que je suis actuellement en train de dev mon prochain serveur moddé, serveur en 1.7.10. Pour le moment j'utilise la version :
Uranium-1710-dev-4-B210-server
, version qui est compatible avec une grosse partie de tous es plugins bukkit/spigot.

Le problème n'est pas du coté serveur, mais plutôt du coté version :mais:.

La 1.7.10 est très facile à dév au niveau mod, mais niveau plugin, c'est pas au top... Beaucoup sont encore incompatibles, et surtout doivent être indispensable pour les serveurs.

Donc, je viens en aide ici, pour chercher une version plus "stable" mais également plus récent. Migré vers la 1.8 ou 1.9.
J'ai fait mes petites recherches, mais je ne trouve pas de réponse à mes attentes. Beaucoup me redirige vers Sponge, et je n'aime pas Sponge (pour cherché des plugins c'est galère je trouve).

Donc j'aimerai savoir, si certains d'entre vous, connait d'autres versions que Sponge, en 1.8 ou 1.9.

Sinon, si vraiment ce n'est pas possible, pourriez-vous m’expliquer comment cherché des plugins sur le site de Sponge, car je galère trop :(.



Cordialement
Kenda_
 

Kenda

Massacreur de zombies
16 Juillet 2016
265
1
2
125
30
www.youtube.com
Bonsoir,
A ma connaissance il n'existe rien de stable en 1.8 (même pas sponge qui n'en était qu'à ces débuts, vaut mieux partir sur sponge 1.10.2 minimum, 1.12.2 au mieux)

Et pour les plugins sponge c'est par ici : https://ore.spongepowered.org/

Bonjour/Bonsoir

Après reflexion, j'aimerai bien passer sous sponge, le seul "problème" qui me bute à resté en 1.7.10 (version de l'enfer), ce sont les "plugins" et la plupart (de ce que j'ai pu rechercher et voir" ne sont pas existant sous version Sponge (ex: BedWars, SkyBlock etc...)

J'aimerai savoir, comment retrouvé l'alternative des plugins Bukkit/spigot en version Sponge (je me doute que ce sois le même nom).
Les configurations des .yml reste les mêmes aussi ?


J'espère que vous comprendrez mon problème.

Cordialement
Kenda
 

Ordwen

Massacreur de zombies
27 Octobre 2014
355
58
140
20
Bonjour/Bonsoir

Après reflexion, j'aimerai bien passer sous sponge, le seul "problème" qui me bute à resté en 1.7.10 (version de l'enfer), ce sont les "plugins" et la plupart (de ce que j'ai pu rechercher et voir" ne sont pas existant sous version Sponge (ex: BedWars, SkyBlock etc...)

J'aimerai savoir, comment retrouvé l'alternative des plugins Bukkit/spigot en version Sponge (je me doute que ce sois le même nom).
Les configurations des .yml reste les mêmes aussi ?


J'espère que vous comprendrez mon problème.

Cordialement
Kenda

Salut, malheureusement Sponge et Bukkit/Spigot sont très différents au niveau de leurs APIs, ce qui contraint de revoir totalement le code d'un plugin Spigot pour le rendre compatible sur Sponge. Spigot étant très largement utilisé, les développeurs sont focalisés (malheureusement) sur cette API, ainsi, à moins qu'un développeur soit soucieux d'adapter ces plugins sur un maximum de plateformes possibles, tu trouveras difficilement des gros plugins existants à la fois sur Spigot et sur Sponge... Mis à part trouver des plugins alternatifs développés par d'autres gens et ne seront peut-être pas terribles, la seule alternative reste de trouver quelqu'un qui voudrait bien te les développer sur mesure... C'est un des gros points noir de Sponge je trouve, proposer des mods et des plugins sur une API spécifique...