Résolu Bug (?) hopper clock

sebzinzin

Nouveau
14 Décembre 2016
7
1
4
Bonjour,
on m'a conseillé de poster ici pour mon souci, alors voilà :
je me suis amusé à faire une tour X-mob et, au moment de mettre en place le mécanisme d'activation (hopper clock), j'ai constaté un genre de bug : quand je mets plusieurs items dans un des deux entonnoirs couplés entre eux, le premier item passe dans le deuxième entonnoir, mais revient dans le premier entonnoir avant que le deuxième item ne soit transmis. J'obtiens donc un mouvement cyclique, mais impossible d'augmenter la période du cycle, ce qui m'empêche de faire fonctionner la tour et donc de voir tomber une foule de monstres et du coup c'est pas drôle.
La même erreur se produit dans une autre carte que j'ai créée en créatif juste pour voir.

Quelqu'un aurait-il des idées ?

PS : j'ai eu un autre bug sur la même carte, avec un autre montage de redstone, respecté à la lettre d'après une vidéo sur Youtube et ça me gâche un peu le plaisir de la carte...

merci et bon(ne)(s) journée / week-end / vacances !

sébastien
 

Oromis

Command-blocker slimesque
Staff
Modérateur
Support
11 Février 2014
3 380
2
1 063
297
23
Bretagne
Lorsque l'un des hoppers ce déverse dans l'autre, alors bloque le récepteur avec un courant redstone pour pas qu'il puisse reverser :)
 

sebzinzin

Nouveau
14 Décembre 2016
7
1
4
Ok, merci déjà !
La vidéo ne semblait pas imposer ça, est-ce que c'est un changement plus ou moins récent ?
Et, si je comprends bien, pour que ça soit réversible, il faut que je trouve un moyen de désactiver l'entonnoir récepteur tant que l'autre n'est pas vide, puis de désactiver le premier tant que le second ne se sera aps à son tour vidé complètement ? Pour un total débutant en redstone comme moi, ça a l'air compliqué ! Je pourrais faire ça avec des comparateurs ?
(désolé si mes questions sont trop basiques...)

sébastien
 
Dernière édition:

Oromis

Command-blocker slimesque
Staff
Modérateur
Support
11 Février 2014
3 380
2
1 063
297
23
Bretagne
Oh, ne t'inquiète pas pour tout ça ;)
Je ne suis moi-même par redstoneur (Vive le command block !)
Voici un petit lien te permettant de voir un swap d'activation des deux entonnoirs en fonctionnement, essaye de t'en inspirer pour ton système :)
 

sebzinzin

Nouveau
14 Décembre 2016
7
1
4
merci beaucoup. Je ne comprends pas bien pourquoi, mais j'ai tout refait comme avant et, cette fois, ça marche. A moi les pluies de Creeper !
je mets en résolu.
sébastien
 
  • J'aime
Reactions: Oromis