Mon "start.bat" crash quand je veux allouer plus de ram

McAllister

Cueilleur de roses
27 Juin 2017
26
0
14
27
Bonjour à tous

J'ai créer un serveur que j'héberge moi même qui est ouvert au public, il tourne sous spigot 1.9, cependant je lui ai alloué seulement 1g de ram, comme il y a quelques freezes, j'aimerais augmenter à 2g, mais quand je fais ça, la console crash, elle s'ouvre et se referme directement.

J'ai mis ça dans mon start.bat (D'ailleurs je ne l'ai pas appelé comme ça, il s'appelle "Cardinal.bat, comprendra qui pourra ^^)
Enfin bref il y a ça:
java -Xms1024M -Xmx1024M -jar spigot.jar

J'ai voulu changer les valeurs de Xms et de Xmx pour mettre 2048 :
java -Xms2048M -Xmx2048M -jar spigot.jar

mais comme je l'ai dit un peu plus haut, la console s'ouvre 1 quart de seconde et elle n'affiche rien.
Le serveur est hébergé sur un PC portable de qui possède 8Go de Ram et un i5

J'ai réussi à augmenter un peu la ram, mais vraiment très peu, je suis passer de 1024M a 1048M et le serveur l'a accepté, la console n'a pas crash, mais dès que j'augmente plus, ça ne marche plus.
Je suis aller chercher sur d'autres forums pour voir si d'autres personne n'avaient pas le même problème que moi mais non.

Si vous pouvez m'aidez :) Merci d'avance

McAllister
 

Rayz27

Minecraftien
7 Avril 2018
254
1
79
75
23
Étrange, pourrais-tu nous donner ton crash-report ? Sinon, essaye ce code:
java -Xms2G -Xmx2G -jar spigot.jar

De plus, ce n'est pas la bonne section.
Je signale :).
 

McAllister

Cueilleur de roses
27 Juin 2017
26
0
14
27
Étrange, pourrais-tu nous donner ton crash-report ?
Le dernier crash report que j'ai eu sur mon serveur était en 2017, donc il n'y pas de rapport avec la console et la ram je pense,
La console s'arrête directement, je sais pas vraiment si elle "crash", je vais essayer le code que tu m'a dit,

Par contre je pensais avoir mis dans la bonne section :/

EDIT: J'ai essayer le message que tu m'a dit, ça ne fonctionne toujours pas, le console s'éteint direct :(
 
Dernière édition:

robin4002

Expert en informatique et systèmes d'information
Staff
Responsable technique
Responsable forum
12 Novembre 2012
19 654
104
2 932
347
25
Alsace
www.minecraftforgefrance.fr
Ouvres un cmd et tapes ce que je t'ai donné, tu aura le résultat de la commande dans ton cmd.
Je suspecte fortement que tu as java 32 bits, si c'est bien le cas il n'y aura aucune mention "64 bits" dans le résultat de cette commande.
 
  • J'aime
Reactions: DiscowZombie

McAllister

Cueilleur de roses
27 Juin 2017
26
0
14
27
J'ai tapé ça dans un cmd, voila ce que la console m'a répondu

java version "1.8.0_171"
Java(TM) SE Runtime Environment (build 1.8.0_171-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.171-b11, mixed mode)

En voyant ça je pense que ça veut dire que j'ai java 64 bit, ---> 64-Bit Server
Après j'ai mis le serveur sur mon gros pc pour faire un test et la je peux mettre Xms et Xmx jusqu'à 4092g(il a lui aussi 8go de ram) donc ça veut dire que ça viendrai d'un problème de puissance ? :confused:
 

McAllister

Cueilleur de roses
27 Juin 2017
26
0
14
27
Je suis aller vérifier la ram restantes sur le pc, je t'envoie les screens, dans le gestionnaire des taches ils disent qu'il reste ~4,3g de libre
 

Fichiers joints

  • Capture.PNG
    Capture.PNG
    13.8 KB · Affichages: 344