Question sur les mises à jour des serveurs

PocketMonster04

Nouveau
14 Mai 2019
5
2
4
16
Salut ! Je ne sais pas vraiment si c'est le meilleur endroit pour poster ça mais je ne savais pas vraiment où le mettre.

Une question m'est venue alors que j'essayais de me connecter sur un serveur cet après-midi alors que je n'avais pas touché au jeu depuis un petit moment. Je n'arrivais pas à me connecter car, la 1.14.1 étant sortie depuis peu de temps, les serveurs auxquels je voulais jouer n'étaient pas encore lançable sur cette version là.

En ressort donc ma question: Savez vous combien de temps mettent les serveurs pour se mettre à jour ?

Ça me taraude car j'ai vraiment envie d'y rejouer.

Merci d'avance pour vos réponses
 

LLIcocoman

Funder of Horyzon incubation project
24 Mars 2012
49
6
78
24
Paris
horyzon.eu
Bonsoir Pocket,

Une version serveur vanilla est disponible dés lors que le client est disponible. Pour les versions moddées telles que Spigot/Bukkit, les versions dev sont déjà disponibles, cela reste au bon vouloir et aux possibilités des administrateurs de serveur de passer ou non à la nouvelle version.

Bonne soirée!
 

PocketMonster04

Nouveau
14 Mai 2019
5
2
4
16
Bonsoir Pocket,

Une version serveur vanilla est disponible dés lors que le client est disponible. Pour les versions moddées telles que Spigot/Bukkit, les versions dev sont déjà disponibles, cela reste au bon vouloir et aux possibilités des administrateurs de serveur de passer ou non à la nouvelle version.

Bonne soirée!
Merci pour ta réponse

Après je pense que la plupart des serveurs se mettront à jour, j'espère juste ne pas avoir à attendre trop longtemps.
 

SamuDu24

Massacreur de zombies
27 Octobre 2014
353
55
140
17
Merci pour ta réponse

Après je pense que la plupart des serveurs se mettront à jour, j'espère juste ne pas avoir à attendre trop longtemps.
Salut !
Ayant moi même un serveur, il s'avère que passer d'une version à une autre est assez compliquée d'un point de vue technique ! En effet, une fois la nouvelle version sortie, tous les plugins qui composent le serveur ne fonctionneront peut-être plus si on met à jour le serveur, il convient donc d'attendre que les versions 1.14 soient stable et d'attendre aussi que les plugins soient mis à jour par leurs développeurs, en général cela ne prend pas longtemps, mais de très gros plugins ou des plugins dont le développement est arrêté peuvent mettre du temps, ou ne jamais se mettre à jour... À ce moment là si nous passons de la 1.13 à la 1.14 par exemple, certains plugins ne fonctionneront plus car le code ne sera plus adapté à la version, parfois ils fonctionnent encore, mais dans le cas de changement d'IDs de blocs, ou quelconque chose importante, ça devient tout de suite beaucoup plus embêtant ! Après, les serveurs peuvent toujours permettre la connexion à un serveur 1.13 avec la version 1.14 par exemple, c'est ce que les serveurs mini-jeux font pour la plupart, avec un plugin nommé Via Version, les connectés n'auront que le contenu de la version du serveur mais pourront se connecter avec des versions supérieures ! Tu peux peut être proposer au serveur sur lequel tu veux te connecter d'ajouter ou de mettre à jour ce plugin, en attendant qu'il passe sur une version supérieure... ;)
 

Detobel36

Créateur de plugins (PhoenixRebirth)
Support
17 Août 2012
9 650
2 122
347
24
Bruxelles - Belgique
www.phoenix-rebirth.fr
Salut,

Au passage @PocketMonster04 sache qu'il est possible de changer la version de ton jeu...
Cela se fait très simplement dans les paramètres de ton launcher. Si tu n'y arrive pas, cherche sur internet, il existe pleins de tutoriel.

Si le serveur sur lequel tu souhaite jouer est en 1.13 il suffit de lancer la version 1.13 du jeu et tu pourra te connecter au serveur.


Cordialement,
Detobel36
 

PocketMonster04

Nouveau
14 Mai 2019
5
2
4
16
Salut !
Ayant moi même un serveur, il s'avère que passer d'une version à une autre est assez compliquée d'un point de vue technique ! En effet, une fois la nouvelle version sortie, tous les plugins qui composent le serveur ne fonctionneront peut-être plus si on met à jour le serveur, il convient donc d'attendre que les versions 1.14 soient stable et d'attendre aussi que les plugins soient mis à jour par leurs développeurs, en général cela ne prend pas longtemps, mais de très gros plugins ou des plugins dont le développement est arrêté peuvent mettre du temps, ou ne jamais se mettre à jour... À ce moment là si nous passons de la 1.13 à la 1.14 par exemple, certains plugins ne fonctionneront plus car le code ne sera plus adapté à la version, parfois ils fonctionnent encore, mais dans le cas de changement d'IDs de blocs, ou quelconque chose importante, ça devient tout de suite beaucoup plus embêtant ! Après, les serveurs peuvent toujours permettre la connexion à un serveur 1.13 avec la version 1.14 par exemple, c'est ce que les serveurs mini-jeux font pour la plupart, avec un plugin nommé Via Version, les connectés n'auront que le contenu de la version du serveur mais pourront se connecter avec des versions supérieures ! Tu peux peut être proposer au serveur sur lequel tu veux te connecter d'ajouter ou de mettre à jour ce plugin, en attendant qu'il passe sur une version supérieure... ;)
Salut,

Au passage @PocketMonster04 sache qu'il est possible de changer la version de ton jeu...
Cela se fait très simplement dans les paramètres de ton launcher. Si tu n'y arrive pas, cherche sur internet, il existe pleins de tutoriel.

Si le serveur sur lequel tu souhaite jouer est en 1.13 il suffit de lancer la version 1.13 du jeu et tu pourra te connecter au serveur.


Cordialement,
Detobel36

Merci pour vos réponses.

Je vais me renseigner pour voir si le serveur à mis en place de quoi permettre aux joueurs d'aller sur les serveurs.
Sinon je me remettrais en 1.13
 
  • J'aime
Reactions: SamuDu24