Soucis plugin citizen2

Jeremy1502

Aventurier
8 Mars 2024
11
0
1
24
Merci beaucoup, j'ai mis mon serveur en 1.20.4 mais par contre mtn c'est le /money qui ne fonctionne pas :s
 

ShE3py

Enbogueuse
Support
26 Septembre 2015
4 305
172
479
247
21
Mìlhüsa
Enfaîte j'ai pris la 1.20 en me disant que j'aurais moins de problème avec les plugins , du coup oui je vais le passer en 1.20.4
Généralement la seule différence entre deux versions mineures c'est des corrections de bugs, donc c'est un peu bête de jouer en 1.20 alors que la 1.20.4 fait la même chose mais avec moins de bugs. C'est pour ça que les développeurs ne mettent à jour que la dernière version (ils vont pas se taper la 1.20 1.20.1 1.20.2 1.20.3 alors que y'a aucune raison de jouer dans ces versions).

Merci beaucoup, j'ai mis mon serveur en 1.20.4 mais par contre mtn c'est le /money qui ne fonctionne pas :s
Renvoie les nouvelles logs du serveur (après avoir fait la commande).
 

ShE3py

Enbogueuse
Support
26 Septembre 2015
4 305
172
479
247
21
Mìlhüsa
Ce que tu as envoyé correspond toujours à un serveur 1.20, il faut envoyer latest.log (il contient les logs du dernier lancement).
 

ShE3py

Enbogueuse
Support
26 Septembre 2015
4 305
172
479
247
21
Mìlhüsa
Code:
[12:48:36] [Server thread/ERROR]: Error occurred while enabling iConomy v6.0.10b (Is it up to date?)
java.lang.NoSuchMethodError: 'java.lang.String org.bukkit.Server.getServerName()'
    at com.iCo6.iConomy.onEnable(iConomy.java:99) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:266) ~[spigot-api-1.20.4-R0.1-SNAPSHOT.jar:?]

[12:48:47] [Server thread/WARN]: [DecentHolograms] Failed to modify player's pipeline. (Vorienne1502)
java.lang.NullPointerException: Cannot invoke "eu.decentsoftware.holograms.api.utils.reflect.ReflectField.getValue(Object)" because "eu.decentsoftware.holograms.api.nms.NMS.PLAYER_CONNECTION_NETWORK_MANAGER_FIELD" is null
    at eu.decentsoftware.holograms.api.nms.NMS.getPipeline(NMS.java:250) ~[?:?]
iConomy n'est toujours pas compatible avec ta version, et DecentHolograms a une erreur de programmation, essaye de le mettre à jour.
 

Jeremy1502

Aventurier
8 Mars 2024
11
0
1
24
Code:
[12:48:36] [Server thread/ERROR]: Error occurred while enabling iConomy v6.0.10b (Is it up to date?)
java.lang.NoSuchMethodError: 'java.lang.String org.bukkit.Server.getServerName()'
    at com.iCo6.iConomy.onEnable(iConomy.java:99) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:266) ~[spigot-api-1.20.4-R0.1-SNAPSHOT.jar:?]

[12:48:47] [Server thread/WARN]: [DecentHolograms] Failed to modify player's pipeline. (Vorienne1502)
java.lang.NullPointerException: Cannot invoke "eu.decentsoftware.holograms.api.utils.reflect.ReflectField.getValue(Object)" because "eu.decentsoftware.holograms.api.nms.NMS.PLAYER_CONNECTION_NETWORK_MANAGER_FIELD" is null
    at eu.decentsoftware.holograms.api.nms.NMS.getPipeline(NMS.java:250) ~[?:?]
iConomy n'est toujours pas compatible avec ta version, et DecentHolograms a une erreur de programmation, essaye de le mettre à jour.
Decentholograms j'ai la version 2.8.6 je ne trouve pas une plus récente