Crash mc moddé 1.18.2 après l'entrée dans le monde.

Ranga_T

Aventurier
28 Juin 2023
18
0
1
21
Bonjour, mon jeu crash quelques secondes après que je sois connecté in-game (que ce sois multi ou solo), Je joue actuellement sur une version modifié du modpack TECC en 1.18.2 (forge 40.2.0) et quand le jeu crash j'ai le code de sortie 1 ou -1073740771. Je sais, après quelques recherches, que le crash est dû (si j'ai bien compris) à java et l'allocation de la ram (?)
Je joins le crash report suite au code de sortie 1. Je précise que je suis le seul qui crash, tous les autres membres du serveur n'ont aucuns problèmes, j'ai une très bonne config (RX6700xt + 32GO de ram) et j'ai alloué presque 10 go de ram à Forge pour MC.

PS: c'est le seul modpack qui me fait crash, je n'est aucuns problèmes sur des modpacks beaucoup plus gros que celui la.
 

Fichiers joints

  • hs_err_pid5332.log
    224.8 KB · Affichages: 62

Ranga_T

Aventurier
28 Juin 2023
18
0
1
21
Bonjour,

As-tu une option dans CurseForge pour changer l'exécutable Java utilisé pour lancer le modpack ?

Cordialement,
ShE3py
oui , si c'est bien la deuxième option ci dessous. je dois changer quelque chose dans ce paramètre ?

cdt,
Ranga .
Capture d’écran 2023-06-28 160107.png
 

ShE3py

Enbogueuse
Support
26 Septembre 2015
3 992
153
447
247
21
Mìlhüsa
Essaye de télécharger une version plus récente de Java :

https://adoptium.net/temurin/releases/?version=17
Operating System: Windows
Architecture: x64
Package Type: JRE
Version: 17 - LTS

Puis de sélectionner ce fichier dans la version de Java utilisée pour installer le modloader Forge ;
Code:
C:\Program Files\Eclipse Adoptium\jre-17.0.7-hotspot\bin\javaw.exe (ou similaire)

Si ça ne marche pas donne-moi le chemin du dossier exact dans lequel tu viens d'installer Java (pas sûre que le chemin que j'ai donné soit le bon).
 

Ranga_T

Aventurier
28 Juin 2023
18
0
1
21
Essaye de télécharger une version plus récente de Java :

https://adoptium.net/temurin/releases/?version=17
Operating System: Windows
Architecture: x64
Package Type: JRE
Version: 17 - LTS

Puis de sélectionner ce fichier dans la version de Java utilisée pour installer le modloader Forge ;
Code:
C:\Program Files\Eclipse Adoptium\jre-17.0.7-hotspot\bin\javaw.exe (ou similaire)

Si ça ne marche pas donne-moi le chemin du dossier exact dans lequel tu viens d'installer Java (pas sûre que le chemin que j'ai donné soit le bon).
le chemin est bon, le jeu ce lance mais le problème est encore la :( , ça crash après quelques secondes dans le monde.

Capture d’écran 2023-06-28 224454.png


code de sortie : -1073740940
 

Fichiers joints

  • hs_err_pid19901.txt
    197.1 KB · Affichages: 34
Dernière édition:

robin4002

Expert en informatique et systèmes d'information
Staff
Responsable technique
Responsable forum
12 Novembre 2012
20 767
155
2 997
347
26
Alsace
www.minecraftforgefrance.fr
Bonjour,
C:\Users\User\curseforge\minecraft\Install\runtime\java-runtime-beta\windows-x64\java-runtime-beta\bin\javaw.exe
Sur ce rapport de plantage, c'est toujours une jvm intégré au launcher de curseforge qui est utilisé et non celle que tu as installée à côté.

Tu es sûr que c'est le dernier rapport de crash en date ?
 

Ranga_T

Aventurier
28 Juin 2023
18
0
1
21
Bonjour,

Sur ce rapport de plantage, c'est toujours une jvm intégré au launcher de curseforge qui est utilisé et non celle que tu as installée à côté.

Tu es sûr que c'est le dernier rapport de crash en date ?
bonjour, oui c'est le dernier en date que j'ai lancé après avoir redémarré le luncher, je vais réessayer aujourd'hui après redémarrage de l'ordi mais je

n'est pas grand espoir que ça marche.

Capture d’écran 2023-06-29 141019.png

edit :
j'ai relancé et le jeu a crash, par contre il n'y a pas de crash report quand il y a ce code de sortie : -1073740940
 
Dernière édition:

ShE3py

Enbogueuse
Support
26 Septembre 2015
3 992
153
447
247
21
Mìlhüsa
Sur ce rapport de plantage, c'est toujours une jvm intégré au launcher de curseforge qui est utilisé et non celle que tu as installée à côté.

Tu es sûr que c'est le dernier rapport de crash en date ?
Bah vu que l'option de CurseForge spécifie que c'est juste pour installer et non exécuter le modloader, je suppose que soit CurseForge ne permette pas de changer la JVM, soit quand c'est dans un autre menu.


Essaye d'ouvrir une invite de commande et d'y taper ces deux commandes :
Bash:
rename "C:\Users\User\curseforge\minecraft\Install\runtime\java-runtime-beta\windows-x64\java-runtime-beta" "java-runtime-beta-orig"
mklink /J "C:\Users\User\curseforge\minecraft\Install\runtime\java-runtime-beta\windows-x64\java-runtime-beta" "C:\Program Files\Eclipse Adoptium\jre-17.0.7-hotspot"

Cela créera un dossier raccourcis qui redirigera le dossier de CurseForge dans le dossier de l'autre version de Java.

edit :
j'ai relancé et le jeu a crash, par contre il n'y a pas de crash report quand il y a ce code de sortie : -1073740940
-1073740940 correspond à STATUS_HEAP_CORRUPTION, c'est un peu la même chose que les crashs précédents avec EXCEPTION_ACCESS_VIOLATION. Essaye de faire ce que j'ai dit ci-haut, mais normalement tu devrais avoir un autre fichier hs_err_pidxxxxx généré pour ce crash.
 

Ranga_T

Aventurier
28 Juin 2023
18
0
1
21
Bah vu que l'option de CurseForge spécifie que c'est juste pour installer et non exécuter le modloader, je suppose que soit CurseForge ne permette pas de changer la JVM, soit quand c'est dans un autre menu.


Essaye d'ouvrir une invite de commande et d'y taper ces deux commandes :
Bash:
rename "C:\Users\User\curseforge\minecraft\Install\runtime\java-runtime-beta\windows-x64\java-runtime-beta" "java-runtime-beta-orig"
mklink /J "C:\Users\User\curseforge\minecraft\Install\runtime\java-runtime-beta\windows-x64\java-runtime-beta" "C:\Program Files\Eclipse Adoptium\jre-17.0.7-hotspot"

Cela créera un dossier raccourcis qui redirigera le dossier de CurseForge dans le dossier de l'autre version de Java.


-1073740940 correspond à STATUS_HEAP_CORRUPTION, c'est un peu la même chose que les crashs précédents avec EXCEPTION_ACCESS_VIOLATION. Essaye de faire ce que j'ai dit ci-haut, mais normalement tu devrais avoir un autre fichier hs_err_pidxxxxx généré pour ce crash.
1688043457958.png


il me dit ça maintenant , je pense que le raccourcie ne fonctionne pas :c
 

ShE3py

Enbogueuse
Support
26 Septembre 2015
3 992
153
447
247
21
Mìlhüsa
Je dirais que le launcher ne suit pas les raccourcis, mais du coup si tu utilises le launcher officiel c'est dans celui-ci que faut changer la version de Java utilisée.

Annule les changements précédents avec ceci :
Bash:
rmdir "C:\Users\User\curseforge\minecraft\Install\runtime\java-runtime-beta\windows-x64\java-runtime-beta"
rename "C:\Users\User\curseforge\minecraft\Install\runtime\java-runtime-beta\windows-x64\java-runtime-beta-orig" "java-runtime-beta"

Puis dans le launcher officiel, va dans Configurations > le modpack > ··· > Modifier >Plus d'options > Exécutable Java > Parcourir >
Code:
C:\Program Files\Eclipse Adoptium\jre-17.0.7-hotspot\bin\javaw
puis Enregistrer.