Configuration Plugin Résolu Message d'erreur console

Escorpiox

Massacreur de zombies
21 Août 2017
73
10
48
18
www.youtube.com
Salut tout le monde.
Je crée cette discussion car j'ai besoin d'aides vis à vis d'un de mes plugins.
Pour information, je suis en train de créer un serveur minecraft en 1.12.1
Sur ce serveur, j'ai le plugin "AdminEssentials" pour version 1.9
Voici le lien si besoin : https://dev.bukkit.org/projects/adminessentials

Seulement, j'ai un problème :/
Problème :
Il faut savoir que ce plugin marche parfaitement mais lorsque j'allume mon serveur ou bien quand je me connecte au serveur, j'ai un message d'erreur jaune qui s'affiche dans la console :

[20:43:59] [Server thread/WARN]: [Fatal Error] :1:1: Fin prématurée du fichier.
[20:43:59] [Server thread/WARN]: org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 1; Fin prématurée du fichier.
[20:43:59] [Server thread/WARN]: at com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(DOMParser.java:257)
[20:43:59] [Server thread/WARN]: at com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(DocumentBuilderImpl.java:339)
[20:43:59] [Server thread/WARN]: at javax.xml.parsers.DocumentBuilder.parse(DocumentBuilder.java:121)
[20:43:59] [Server thread/WARN]: at adminessentials.main.UpdateChecker.updateNeeded(UpdateChecker.java:34)
[20:43:59] [Server thread/WARN]: at adminessentials.main.Main.onEnable(Main.java:39)
[20:43:59] [Server thread/WARN]: at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264)
[20:43:59] [Server thread/WARN]: at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337)
[20:43:59] [Server thread/WARN]: at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:402)
[20:43:59] [Server thread/WARN]: at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:380)
[20:43:59] [Server thread/WARN]: at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:329)
[20:43:59] [Server thread/WARN]: at net.minecraft.server.v1_12_R1.MinecraftServer.t(MinecraftServer.java:422)
[20:43:59] [Server thread/WARN]: at net.minecraft.server.v1_12_R1.MinecraftServer.l(MinecraftServer.java:383)
[20:43:59] [Server thread/WARN]: at net.minecraft.server.v1_12_R1.MinecraftServer.a(MinecraftServer.java:338)
[20:43:59] [Server thread/WARN]: at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:272)
[20:43:59] [Server thread/WARN]: at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:545)
[20:43:59] [Server thread/WARN]: at java.lang.Thread.run(Thread.java:745)

J'espère avoir été le plus clair/précis à vos yeux.
Si vous avez des questions, n'hésitez pas.

Développeur Java : @DiscowZombie
 
Dernière édition:
C

Compte supprimée

Invité
Pour Essentials, le problème vient p'têtre du fait qu'il soit en 1.9 ?
 

DiscowZombie

Développeur
Staff
Modérateur
Support
2 Mars 2017
2 641
931
248
19
Alsace
www.discowzombie.fr
Et bien, à vrai dire, ce message d'erreur ne l'empêche pas de fonctionner. Il marche très bien. Tout fonctionne parfaitement. Mais j'aimerai n'avoir aucun message d'erreur dans la console.
Certes c'est l'idéal mais on ne peut pas dire que tu es trop le choix. S'il n'existe pas en 1.12.1, à part trouver un équivalent ou toucher au code tu n'a aucune solution :/ D'ailleurs tu as vérifié que l'erreur n'apparait pas en 1.9? :)
 

Escorpiox

Massacreur de zombies
21 Août 2017
73
10
48
18
www.youtube.com
Certes c'est l'idéal mais on ne peut pas dire que tu es trop le choix. S'il n'existe pas en 1.12.1, à part trouver un équivalent ou toucher au code tu n'a aucune solution :/ D'ailleurs tu as vérifié que l'erreur n'apparait pas en 1.9? :)
Je viens tout juste d'essayer en mettant le serveur en 1.9 et le message d'erreur est toujours là :/
J'ai même testé en enlevant tous mes autres plugins pour voir si ce n'était pas une collision entre 2 plugins mais rien n'y fait : Le message d'erreur est toujours là :/
 
Dernière édition:

Escorpiox

Massacreur de zombies
21 Août 2017
73
10
48
18
www.youtube.com
Ok, c'est bien ce que je pensais, c'est dû à la mise à jour ^^ Essaye de prendre une version inférieur voir si le message apparait toujours :)
Justement, j'ai essayé de prendre la version "1.2" du plugin sur le site : https://dev.bukkit.org/projects/adminessentials/files
En faîte, c'est la version 1.1.3 du plugin (Vue dans la console au lancement)
Et au lancement de cette version inférieure, le message d'erreur est toujours présent. Et si je passe à la version 1.1.2 du plugin, il y a des fonctionnalités en moins dont j'ai besoin :/
 

DiscowZombie

Développeur
Staff
Modérateur
Support
2 Mars 2017
2 641
931
248
19
Alsace
www.discowzombie.fr
Ok, donc ne rétrograde pas, ça serait dommage ; surtout si le message d'erreur est toujours là.

Le point positif c'est que le problème est global et qu'il sera corriger dans la prochaine version, tu n'a plus qu'à l'attendre bien sagement :p


PS: Je vais voir pour ton second problème, je te dit ça rapidement ;)
 

Pour voir moins d'annonces créez un compte ou connectez-vous.